Choppy lines in data recording / preview

Help on issues you run into with LapTimer; in case you have a question on how to use LapTimer, use the forum "Using LapTimer" instead
Post Reply
dpsend1
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 4
Joined: Wed Jun 22, 2016 9:19 pm

Choppy lines in data recording / preview

Post by dpsend1 » Sat Oct 15, 2016 2:27 am

Using VBOX Sport (20Hz) and consistently getting choppy lines this year. Lose connection somewhere? iPhone 6S in custom iPhone RAM mount bolted to dash, external magnetic antenna. Thoughts? Thanks

Image
User avatar
Harry
Site Admin
Site Admin
Posts: 9260
Joined: Sun Sep 12, 2010 10:32 am
Location: Siegum, Germany
Contact:

Re: Choppy lines in data recording / preview

Post by Harry » Sat Oct 15, 2016 8:33 am

Please increase the accelerometer update rate to something like 60 Hz. As a rule of thumb, it should be 3 times higher than the GPS rate to make the fusion mechanism work fine. You can find the setting in LapTimer ‣ Administration ‣ Settings ‣ Expert Settings ‣ Accelerometer Tweaks. The default is 30 Hz - good enough for GPS receivers up to 10 Hz.

For you existing VBOX recording, try the acceleration re-calculatipn from Lap List ‣ your lap ‣ Recalculate ‣ Acceleration. It can be hard to set the smoothing right for 20 Hz recordings, you need to move the smoothing slider in very small steps.

- Harry
Image Image Image Image
ckowalc
20 or more Posts ★★★
20 or more Posts ★★★
Posts: 77
Joined: Thu May 14, 2015 7:33 pm

Re: Choppy lines in data recording / preview

Post by ckowalc » Sun Nov 06, 2016 9:26 pm

Harry,

I've got a similar issue going on I think but I'm using the QStarz BT-Q818XT (10 Hz GPS) and the default 30Hz accelerometer update rate.

My Oct 22nd track day seems like the recordings earlier in the day looked fine but later in the day look choppy or have no colored accel. on the lap trace. The lat. accel. chart looks okay though.

Example #1
Screenshot_2016-11-06-15-08-22.png
Screenshot_2016-11-06-15-08-22.png (94.85 KiB) Viewed 1012 times
Example #2
Screenshot_2016-11-06-15-09-04.png
Screenshot_2016-11-06-15-09-04.png (133.9 KiB) Viewed 1012 times
Screenshot_2016-11-06-15-09-40.png
Screenshot_2016-11-06-15-09-40.png (71.55 KiB) Viewed 1012 times
ckowalc
20 or more Posts ★★★
20 or more Posts ★★★
Posts: 77
Joined: Thu May 14, 2015 7:33 pm

Re: Choppy lines in data recording / preview

Post by ckowalc » Sun Nov 06, 2016 9:27 pm

Then, my latest track day most of the lap traces look bare except of a few spikes. The lat. accel. charts are just noisy data. See below:
Screenshot_2016-11-06-15-10-56.png
Screenshot_2016-11-06-15-10-56.png (42.21 KiB) Viewed 1012 times
Screenshot_2016-11-06-15-11-10.png
Screenshot_2016-11-06-15-11-10.png (47.27 KiB) Viewed 1012 times
Screenshot_2016-11-06-15-13-25.png
Screenshot_2016-11-06-15-13-25.png (85.53 KiB) Viewed 1012 times
ckowalc
20 or more Posts ★★★
20 or more Posts ★★★
Posts: 77
Joined: Thu May 14, 2015 7:33 pm

Re: Choppy lines in data recording / preview

Post by ckowalc » Sat Nov 12, 2016 11:35 pm

Any update on this?
User avatar
Harry
Site Admin
Site Admin
Posts: 9260
Joined: Sun Sep 12, 2010 10:32 am
Location: Siegum, Germany
Contact:

Re: Choppy lines in data recording / preview

Post by Harry » Sun Nov 13, 2016 10:31 am

Please use Lap List ‣ lap with bad acceleration readings ‣ Recalculate ‣ Acceleration. This will allow you to replace measured acceleration by smooth calculated ones. I have no idea how the issue shown is created, but I will monitor if I see the patterns again. Using a 10 Hz GPS with 30 acceleration should be fine as (besides using internal sensors) it is the most common combo used.

- Harry
Image Image Image Image
ckowalc
20 or more Posts ★★★
20 or more Posts ★★★
Posts: 77
Joined: Thu May 14, 2015 7:33 pm

Re: Choppy lines in data recording / preview

Post by ckowalc » Mon Nov 14, 2016 10:23 pm

Hmm, the recalculate function doesn't seem to help. Must be something wrong with the data coming from the accelerometer. I'll let you know if this trend continues in future track days.
User avatar
Harry
Site Admin
Site Admin
Posts: 9260
Joined: Sun Sep 12, 2010 10:32 am
Location: Siegum, Germany
Contact:

Re: Choppy lines in data recording / preview

Post by Harry » Mon Nov 14, 2016 10:32 pm

When recalculating acceleration, measured values are purged and replaced by the calculation. It has no influence on the result. In case you get the same result when recalculating, there is some other issue we need to pursue. For the recalculation, please make sure you smooth values strongly. Higher GPS update rates require lots of smoothing.

Harry
Image Image Image Image
Post Reply