LeLink OBD2 BLE

Discussion related to external OBD and other sensors
Post Reply
Andrey_KK
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 3
Joined: Wed Aug 22, 2018 4:03 am

LeLink OBD2 BLE

Post by Andrey_KK » Wed Aug 22, 2018 4:13 am

Dear Harry,

Currently I am trying to connect new OBD BLE Adapter called LeLink http://www.outdoor-apps.com/enginelink.html.
I use iOS 11.4.1 and latest Gran Prix edition of LapTimer.
As I understood, I need to enter custom UUID in Expert Mode for LapTimer to see the sensor. What should I do with read and write UUIDs? Can I leave them empty? Can you please add this LeLink in your sensors list for the future versions of LapTimer?

Kind regards,
Andrey
User avatar
Harry
Site Admin
Site Admin
Posts: 9482
Joined: Sun Sep 12, 2010 10:32 am
Location: Siegum, Germany
Contact:

Re: LeLink OBD2 BLE

Post by Harry » Wed Aug 22, 2018 2:01 pm

Hi,

There are dozens of sensors around, and I can't buy and integrate them all. For zero configuration, please stick with sensors listed on LapTimer's compatibility pages (see www.gps-laptimer.de).

For users with BT LE knowledge, there is indeed a backdoor to connect sensors not supported otherwise. For BT LE sensors, you need to set a device name pattern (or the actually name your devices shows up with), the service UUID and the read and write characteristic UUIDs. You can find all this data using an app like LightBlue.

- Harry
Image Image Image Image
Andrey_KK
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 3
Joined: Wed Aug 22, 2018 4:03 am

Re: LeLink OBD2 BLE

Post by Andrey_KK » Thu Aug 23, 2018 10:31 am

Hi Harry,

Thanks a lot for your reply. I totally understand that you cannot include all the possible BLEs into pre-configured setup.
I found another thread on this BLE where you already replied and I followed your instructions- viewtopic.php?f=6&t=4607

Managed to connect through LapTimer but no data is received but connection is green. I assume it is due to wrong read and write UUIDs but I cannot find them like in the thread above.
Thanks a lot for any advice!

Regards,
Andrey
Attachments
fullsizeoutput_193c.jpeg
fullsizeoutput_193c.jpeg (122.54 KiB) Viewed 347 times
fullsizeoutput_193b.jpeg
fullsizeoutput_193b.jpeg (164.55 KiB) Viewed 347 times
fullsizeoutput_1939.jpeg
fullsizeoutput_1939.jpeg (178.8 KiB) Viewed 347 times
User avatar
Harry
Site Admin
Site Admin
Posts: 9482
Joined: Sun Sep 12, 2010 10:32 am
Location: Siegum, Germany
Contact:

Re: LeLink OBD2 BLE

Post by Harry » Sat Aug 25, 2018 7:56 pm

You may try FFE1 for both the read and write characteristic. It may be a good idea to wait for next week - LapTimer v22 will get available. It has the BT LE significantly changed, this version definitively works with devices using the same GATT for read and write.

Harry
Image Image Image Image
Andrey_KK
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 3
Joined: Wed Aug 22, 2018 4:03 am

Re: LeLink OBD2 BLE

Post by Andrey_KK » Sun Aug 26, 2018 2:47 pm

Thanks for advice! Managed to get connection with Service UUID of FFF0 and read/write FFF1 but no data. Laptimer shows connection and rate 70-80 Hz but no data at all. So I returned the device and bough compatible TONWON BLE. Now everything works.
I have also SCANEX BLE left from old times that does not work showing the same 70-80 Hz connection with Service UUID of FFF0 and read/write FFF1. So will be waiting for the update.
Post Reply