Shaky Video with HLT, Clean without

Any discussion on using LapTimer. Please use this forum in case you need guidance on how to use LapTimer or perform a certain operation
Post Reply
bldn10
10 or more Posts ★
10 or more Posts ★
Posts: 17
Joined: Fri Oct 21, 2011 5:58 pm

Shaky Video with HLT, Clean without

Post by bldn10 »

I just got an iPhone 11 and was really disappointed in the in-car video quality - too shaky to watch. This was w/ the same RAM windshield mount that I used w/ my old iPhone 5S that made nice and clean videos. I tried it just w/ the phone video and it is perfect. Back on LapTimer and it is shaky again. Is there a setting in Lap Timer that I need to change?
User avatar
Harry
Site Admin
Site Admin
Posts: 10004
Joined: Sun Sep 12, 2010 10:32 am
Location: Siegum, Germany
Contact:

Re: Shaky Video with HLT, Clean without

Post by Harry »

LapTimer ‣ Race ‣ Timer ‣ Video ‣ select internal cam ‣ Preview ‣ Tool button in the top right.
Disabling stabilization here will improve the video, but in car videos with late smartphones are far from perfect in general.
The reason is the optical image stabilization built into modern phones. They start vibrating when coupled to engine frequency.
Some users attach a small magnet near the lens - but it may damage the phone on the long run.

- Harry
Image Image Image Image
Searya
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 8
Joined: Tue Sep 15, 2020 5:41 am

Re: Shaky Video with HLT, Clean without

Post by Searya »

Not sure it will work for you but I have an iPhone XR and had the same shaky video problem. I tried lots of different mounts but no luck.

I then found the setting to switch to use front camera and bam perfect shake free footage! Video still looks great too.
User avatar
Harry
Site Admin
Site Admin
Posts: 10004
Joined: Sun Sep 12, 2010 10:32 am
Location: Siegum, Germany
Contact:

Re: Shaky Video with HLT, Clean without

Post by Harry »

Searya wrote: Tue Sep 15, 2020 5:48 am Not sure it will work for you but I have an iPhone XR and had the same shaky video problem. I tried lots of different mounts but no luck.

I then found the setting to switch to use front camera and bam perfect shake free footage! Video still looks great too.
Front cams do not have optical image stabilization thus do not start to vibrate from engine vibrations.

- Harry
Image Image Image Image
bldn10
10 or more Posts ★
10 or more Posts ★
Posts: 17
Joined: Fri Oct 21, 2011 5:58 pm

Re: Shaky Video with HLT, Clean without

Post by bldn10 »

" use front camera "
But then you can't monitor lap times, etc. - kinda defeats the purpose. Might as well have a dedicated camera.

Harry, if the problem is w/ the stabilization in the phone, why is it that that videos are perfect when using the phone only w/ no HLT? Seems like it is going through HLT that is the problem.

Bill/Memphis
User avatar
Harry
Site Admin
Site Admin
Posts: 10004
Joined: Sun Sep 12, 2010 10:32 am
Location: Siegum, Germany
Contact:

Re: Shaky Video with HLT, Clean without

Post by Harry »

All phones I have seen shake with LapTimer, showed shake with the phone's camera app too...
There is an option to turn off *software* image stabilization you can try: LapTimer ‣ Race ‣ Video ‣ internal cam ‣ Preview ‣ Tools menu in the top right. The hardware issue with a engine vibration triggered moving lens cannot be fixed by a specific app.

- Harry
Image Image Image Image
bldn10
10 or more Posts ★
10 or more Posts ★
Posts: 17
Joined: Fri Oct 21, 2011 5:58 pm

Re: Shaky Video with HLT, Clean without

Post by bldn10 »

Harry, I don't understand any of this, I'm just a naive reporter of the facts. The season hasn't started so all I can do is run these experiments in my SUV on the street. Turning stabilization OFF in HLT reduces the shaking but it is still not as stable as the camera app. W/ the app the world in front of me looks virtually still but I can see at the hood bouncing up and down over bumps.
Post Reply