OBD2 Update Rate Low

Any discussion on using LapTimer. Please use this forum in case you need guidance on how to use LapTimer or perform a certain operation
Post Reply
Fsousa91
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 2
Joined: Sat Dec 29, 2018 3:04 am

OBD2 Update Rate Low

Post by Fsousa91 » Sun Apr 07, 2019 8:07 pm

[*] hi all,

I have just upgraded my Harry’s Laptimer app from petrolhead to Grand Prix, and I’ll use it with XGPS160 and OBDLink MX+ Bluetooth.

I’ve tested this set, but encountered the “OBD2 Update Rate” warning. Anyone has any advice on it? Maybe two Bluetooth devices don’t work (XGPS and OBD)? Or should I deactivate the OBDlink app when using Harry’s?

I’ve already used the OBD app eith the car running, and encountered no problem, so that’s why I believe that’s not a hardware issue.

Thanks! Best,
User avatar
Harry
Site Admin
Site Admin
Posts: 9983
Joined: Sun Sep 12, 2010 10:32 am
Location: Siegum, Germany
Contact:

Re: OBD2 Update Rate Low

Post by Harry » Mon Apr 08, 2019 6:24 pm

Hello,

The OBDLink app does not disconnect the MX+ when sent to background. So it is mandatory to kill it when using LapTimer. It is not possible to access the accessory from two apps at the same time. In case you face the low update rate issue after killing the OBDLink app, try this Expert Settings to trade optimization against stability:

OBD Tweaks / Adaptive Timing ‣ Enabled
OBD Tweaks / ECUs Addressed ‣ ECM
OBD Tweaks / Disable Parallel Requests ‣ YES

Restart LapTimer afterwards. In case you a stable connection afterwards, you can try enabling one of Disable Parallel Requests and Adaptive Timing again.

- Harry
Image Image Image Image
Fsousa91
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 2
Joined: Sat Dec 29, 2018 3:04 am

Re: OBD2 Update Rate Low

Post by Fsousa91 » Mon Apr 08, 2019 6:49 pm

Great, thank you Harry!
I’ll have this set tried later today and get back with updates!
ereynold60
20 or more Posts ★★★
20 or more Posts ★★★
Posts: 87
Joined: Fri Mar 13, 2015 9:31 pm

Re: OBD2 Update Rate Low

Post by ereynold60 » Mon Apr 08, 2019 8:02 pm

FWIW - I also use Android with XGPS160 at 10hz and OBDlink MX BT... OBD rate for me varies between 4-6 hz.
Post Reply