Page 1 of 1

What to do Harry ?

Posted: Sat Sep 29, 2012 12:36 pm
by Saturnalian
Hi Harry,

I've been using Lap Timer Pro for a little over a year now, riding a motorcycle at tracks around Australia.
In that time I have tested 4 different types of GPS dongle, until I found the best working solution.
I have been sceptical about telling people in the wider motorcycle trackday community about your app, until i was sure it was a reliable trouble free option
As you know I have created , tested and successfully submitted a number of tracksets to your App that people are now downloading and using themselves.
My last 3 trackdays on Version 15 I was getting laps recording every session ,my splits working, auto stop perfect etc and making some progress with the data.
I began to post amongst my riding community about your App, and how helpful, and easy to use it is.

Last week i did my first track day on version 16 and......nothing !!!
Not a single session ,not a single lap, all day.
Before going out for each session we had good GPS, (Dual XGPS150) the clock was spinning waiting for its trigger, into my pocket and away...
I followed all of the usual procedures, tried all of the usual tweaks, detection corridor, energy saving off, display sleep set to never etc and NOTHING...
Usually when i came back in the App was no longer active, sometimes it was back at the help screen, sometimes it had completely quit as it restarted when i selected it again.

I'm afraid for Motorcyclists who move around on the bike, can't power the phone etc i may have spoken to highly to soon.
It is incredibly disillusioning for me, and expensive, ( a trackday here can cost $ 250 - $450 ) to get no data, no results etc

I can only guess at the cause of this....

My guesses are as follows-
Something to do with the calibration changing as the new screen setup keeps changing orientation ?
Something to do with the way the App works with Location services now. I disable it for Laptimer Pro when using the Dual unit as per your instruction ?
Something else ??

I should add at this point that i picked up an iphone 5 this week and the App crashes now on startup if Location services isn't turned on.

I don't know what else to say, i'm at a loss, I can't send you the trace log because the update turned the preference off.

Back to you,


Re: What to do Harry ?

Posted: Sat Sep 29, 2012 12:58 pm
by Harry

Well, lets try to find out what's going on, I'm sure that's nothing that cannot be solved. My first guess would be it is related to rotation - as this has been one of the major changes between 15 and 16. Usually you have your iPhone in sight. As you wear it in your pocket, you will not see it in case you get warnings. When operated this way, I'd recommend turning rotation completely off. So please double press the Home button, shift the task bar to the right until you see the lock button. Lock you iPhone orientation here. Other than that, please always check the update rate GPS delivers - sometimes accessory connections get disconnected. In this cases, LapTimer will usually show 0 Hz after a while.

- Harry

Re: What to do Harry ?

Posted: Sat Sep 29, 2012 1:02 pm
by Saturnalian
Thanks Harry,

I'll keep you posted. While we're at it, is the correct procedure still to disable location services for the App when using an external GPS ?

Many thanks,


Re: What to do Harry ?

Posted: Sat Sep 29, 2012 1:09 pm
by Harry
Location service should be turned ON to have a valid fall back available in case other sources fail. Please note LapTimer will not activate the internal GPS in case an external GPS is connected. Instead, it sits in background - shown as 'available'. Resource and sensor access has been changed in iOS6, cutting the rope for either location service or the photo library may cause trouble.

- Harry

Re: What to do Harry ?

Posted: Fri Jan 11, 2013 4:33 am
by Saturnalian
Hi Harry,

I got out on track again just before Christmas time and can happily report that with the screen rotation locked and Location services on i was getting data in just about every session for the day.
I think there was 1 session where i had forgotten to lock the rotation and we had success with the data on that as well, so perhaps it was the Location services being off that created the problem.

The next step for me is to work out why my speedo, which is calibrated with a speedo healer and checked for accuracy with HLT Speedo, is showing a top speed per lap of 234Km/Hr when my lap data is saying 214 Km/Hr.

Keep up the good work....