Vgate iCar Pro Not Working Anymore?

Help on issues you run into with LapTimer; in case you have a question on how to use LapTimer, use the forum "Using LapTimer" instead
Post Reply
BonLap
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 7
Joined: Mon Jul 26, 2021 8:01 pm

Vgate iCar Pro Not Working Anymore?

Post by BonLap »

Has anyone manage to make Vgate iCar Pro work with HLT? Is it still working now?

I’ve been using Vgate iCar Pro without inputting any Expert Settings during the track day seasons in 2019 and 2020. Howover, starting this Jun for the track day season this year, I haven’t been able to get any OBDII data to HLT. HLT says it doesn’t receive the data at the expected rate and status stays red.

Yesterday I went into HLT’s Expert Settings to update the following values like someone if the Forum suggested, unfortunately it still doesn’t connect (see the attached Sensor List, where Tonwon still shows up with no obvious reason and there is one more “Custom BTLE OBD” showing up but not connected). I’ve also verified below values against LightBlue (see attached too).

@Harry, any recommendations pls?

“IOS-Vlink",
service UUID: 18F0,
read Characteristic: 2AF0,
write Characteristic 2AF1
Attachments
62A2AF60-4A87-4F96-821B-EAC0F75B037B.jpeg
62A2AF60-4A87-4F96-821B-EAC0F75B037B.jpeg (151.24 KiB) Viewed 314 times
9B47D425-2170-4384-B24C-23C35B30956C.jpeg
9B47D425-2170-4384-B24C-23C35B30956C.jpeg (172.69 KiB) Viewed 314 times
0515AABE-88A2-4B32-A10F-6BEEBDBA04A2.jpeg
0515AABE-88A2-4B32-A10F-6BEEBDBA04A2.jpeg (159.2 KiB) Viewed 314 times
Harry's GPS LapTimer Petrolhead Edition v24.5
Apple iPhone XR iOS 14.5.1
Vgate iCar Pro
User avatar
Harry
Site Admin
Site Admin
Posts: 10124
Joined: Sun Sep 12, 2010 10:32 am
Location: Siegum, Germany
Contact:

Re: Vgate iCar Pro Not Working Anymore?

Post by Harry »

The TONWON BTLE 4.0 adapter uses the device name "IOS-Vlink" by default. I assume there are several brands using the same manufacturer using the same technical name. The characteristics listed above are the same the TONWON uses too. So please start with removing the custom OBD adapter - it will duplicate things and may result in access conflicts.

I do not have experience with the Gate iCar adapter - although it may work.

You can find instructions on how to trouble shoot OBD adapters here: viewtopic.php?f=39&t=1500
Try to set a know OBD Default Protocol in addition. This will work around issues with negotiation the bus protocol between adapter and car.

Please do not use an OBD adapter not delivering stable update rates during track days. This will result in problems with recordings in general. Better no OBD than no data at all...

- Harry
Image Image Image Image
BonLap
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 7
Joined: Mon Jul 26, 2021 8:01 pm

Re: Vgate iCar Pro Not Working Anymore?

Post by BonLap »

Thx @Harry.

My Vgate iCar Pro worked before during the track day seasons in 2019 and 2020 (without inputting any Expert Settings). Not sure why it isn't working this year. I've only started playing with the Expert Settings after HLT receives no OBDII data.

My car is the 2018 BMW.

I've tried below (in order of sequence) but it still doesn't work:
a) Inputting the Peripheral Name and UUID as per my original post
b) Changing Throttle PID from Position D to Default
c) Changing ELM327 Type from Request/Reply to Automatic Replies
d) Setting ECUs Addressed to ECM or TCM instead of ALL
e) Setting Adaptive Timing to Enabled instead of Optimized
f) Removing values of Peripheral Name and UUID (blank values now)
g) Reverting settings in d) and e) above back to ALL and Optimized

Should the next step be logging the connection information via Harry's GPS/OBD Buddy and sending it to you for further analysis?

Thx.
Harry's GPS LapTimer Petrolhead Edition v24.5
Apple iPhone XR iOS 14.5.1
Vgate iCar Pro
BonLap
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 7
Joined: Mon Jul 26, 2021 8:01 pm

Re: Vgate iCar Pro Not Working Anymore?

Post by BonLap »

Hi @Harry, I’ve just emailed you the log from Harry's GPS/OBD Buddy. Your assistance will be much appreciated.

Thx.
Harry's GPS LapTimer Petrolhead Edition v24.5
Apple iPhone XR iOS 14.5.1
Vgate iCar Pro
User avatar
Harry
Site Admin
Site Admin
Posts: 10124
Joined: Sun Sep 12, 2010 10:32 am
Location: Siegum, Germany
Contact:

Re: Vgate iCar Pro Not Working Anymore?

Post by Harry »

Hello,

I finally checked the log. LapTimer sends a number of requests, but does not receive an answer. To me it looks like there is a problem on communication level between app and adapter. Please switch to one of adapters listed on http://www.gps-laptimer.de/compatibility/ios or http://www.gps-laptimer.de/compatibility/android. Although I cannot guarantee operation with every car, chances it will work are a lot better when using on of the tested solutions.

- Harry
Image Image Image Image
BonLap
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 7
Joined: Mon Jul 26, 2021 8:01 pm

Re: Vgate iCar Pro Not Working Anymore?

Post by BonLap »

Thx @Harry. When I was to give up on the Vgate iCar Pro, I changed the “Default Protocol” in “OBD Tweaks” to “SAE J1850 PWM” (I tried “SAE J1850 VPW” and it seemed to work too), the status of OBD dongle was no longer in red. Could you please help verify from the below screenshots if connection is fine now?

Just saw from another post that you suggested to use “ISO 15765-4 CAN (11 bit, 500 kbps). Should I use that instead of “SAE J1850 PWM” for my 2018 BMW?
Attachments
294E0E00-99FF-4E4A-A9B9-76135A70877C.png
294E0E00-99FF-4E4A-A9B9-76135A70877C.png (208.57 KiB) Viewed 222 times
06F322DD-E84E-41AC-ADB8-3E58F8D16D54.png
06F322DD-E84E-41AC-ADB8-3E58F8D16D54.png (351.48 KiB) Viewed 222 times
Harry's GPS LapTimer Petrolhead Edition v24.5
Apple iPhone XR iOS 14.5.1
Vgate iCar Pro
BonLap
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 7
Joined: Mon Jul 26, 2021 8:01 pm

Re: Vgate iCar Pro Not Working Anymore?

Post by BonLap »

more attachments
Attachments
415FB51C-8C7E-4EEF-B94E-1D683392236A.png
415FB51C-8C7E-4EEF-B94E-1D683392236A.png (605.02 KiB) Viewed 222 times
E82A7919-B334-4E99-AEB7-8C4571670BA4.png
E82A7919-B334-4E99-AEB7-8C4571670BA4.png (841.24 KiB) Viewed 222 times
Harry's GPS LapTimer Petrolhead Edition v24.5
Apple iPhone XR iOS 14.5.1
Vgate iCar Pro
User avatar
Harry
Site Admin
Site Admin
Posts: 10124
Joined: Sun Sep 12, 2010 10:32 am
Location: Siegum, Germany
Contact:

Re: Vgate iCar Pro Not Working Anymore?

Post by Harry »

In the top of Sensor Information, you can see that the adapter negotiated the CAN11/500 protocol. Default protocol is kind of a starting point for protocol negotiation…

Anyway, I’d suggest to set CAN as default. Keep my fingers cross.

Harry
Image Image Image Image
BonLap
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 7
Joined: Mon Jul 26, 2021 8:01 pm

Re: Vgate iCar Pro Not Working Anymore?

Post by BonLap »

Thx @Harry I'll update the Protocol accordingly.
Harry's GPS LapTimer Petrolhead Edition v24.5
Apple iPhone XR iOS 14.5.1
Vgate iCar Pro
Post Reply