No Engine Data after Update to Grand Prix

Help on issues you run into with LapTimer; in case you have a question on how to use LapTimer, use the forum "Using LapTimer" instead
Post Reply
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 1
Joined: Mon Nov 04, 2019 8:50 am

No Engine Data after Update to Grand Prix

Post by Legstrong » Mon Nov 04, 2019 9:26 am

I used Petrolhead for some times and it worked perfectly fine with my Android phone and OBD adaptor. I recently upgraded to Grand Prix and installed BLE TPMS then went for a track session. With all default settings, the record shows no OBD data at all, G force and tire information are fine.

In the engine panel, the rpm freeze at a value and no pedal info showing, like connected once and then lost (but there are some other info showing dynamically). I tried to change the OBD Tweaks-Adaptive Timing to "Aggressive", the rpm could show dynamically, but still no pedal info.

I also tried uninstalled the app and re-installed Petrolhead, it worked fine with engine data. But after upgraded to Grand Prix same OBD issue happened. I am not sure about other expert settings so did not change them.

Any idea?
User avatar
Site Admin
Site Admin
Posts: 9983
Joined: Sun Sep 12, 2010 10:32 am
Location: Siegum, Germany

Re: No Engine Data after Update to Grand Prix

Post by Harry » Mon Nov 04, 2019 12:42 pm

The only thing I can think of is that the TPMS sensors connected influence this. When upgrading Petrolhead to GrandPrix, you are still running the same app - with addition features enabled. Please remove the TPMS sensors and try again with both the Petrolhead base version and after enabling GrandPrix features. For further troubleshooting, please add information on the OBD adapter used.

- Harry
Image Image Image Image
Post Reply