Videos missing - can't add them either

Help on issues you run into with LapTimer; in case you have a question on how to use LapTimer, use the forum "Using LapTimer" instead
User avatar
enroscado
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 6
Joined: Sun Mar 31, 2019 4:43 pm

Videos missing - can't add them either

Post by enroscado » Sun Mar 31, 2019 5:21 pm

Hi all,

First post here, even though I have been using HLT for a few years now.

Setup:
- iPhone 6S plus
- iOS 12.1.4
- HLT Grand Prix Edition v22.1.4
- GoPro Hero 3+ Black - v03.03
- Harry's MultiCam v20.0
Multicam control settings:
- Multicam preset: Master
- External cam: Hero3/3+
- Hero3/3+ Wifi password: (password)
- Use iCloud: Yes
- Auto Receive Videos: Yes

I did a track day, and recorded video with my GoPro only (first time doing it like this, before always phone + GoPro).
I was able to begin each session normally: status was all green, GoPro switched on and started recording normally from within HLT.
Before starting each session, using 'Classic' view, I tapped on video and in 'Video Operation' I selected the last option to the right: external cam only.

My problem is that I cannot find the videos from within HLT for overlaying / exporting. Tried going into the lap details, editing, and adding video, but HTL does not see the videos.

Initially, GoPro videos were not saved in 'Photos' (GoPro & phone connected via wifi). Uploaded the videos via iCloud to see if it would change anything, but still HTL does not see the videos, even though I can see them and play them within 'Photos'.

Did I miss something? Any ideas, please?

Thank you,

enroscado
User avatar
Harry
Site Admin
Site Admin
Posts: 9489
Joined: Sun Sep 12, 2010 10:32 am
Location: Siegum, Germany
Contact:

Re: Videos missing - can't add them either

Post by Harry » Mon Apr 01, 2019 8:04 pm

You need to transfer the GoPro video to the smartphone manually, Photos app is o.k. To link laps and video, select one lap of the session from Lap List and scroll to the Video section. Tap the empty video placeholder and press the Re-Link button (two cams icon). Select the video from the list shown and your are done. See Video Documentation available from www.gps-laptimer.de/documentation for more information and further instructions.

- Harry
Image Image Image Image
User avatar
enroscado
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 6
Joined: Sun Mar 31, 2019 4:43 pm

Re: Videos missing - can't add them either

Post by enroscado » Mon Apr 01, 2019 9:05 pm

Hi Harry,

Thanks for your reply, and since we are at it, for the very cool app.

The problem I have is that HLT does not see the videos, even though the videos are in the phone, and I can see them and watch them within the Photos app.

Best,

Anibal
User avatar
Harry
Site Admin
Site Admin
Posts: 9489
Joined: Sun Sep 12, 2010 10:32 am
Location: Siegum, Germany
Contact:

Re: Videos missing - can't add them either

Post by Harry » Mon Apr 01, 2019 9:34 pm

Check permissions granted to LapTimer in iOS’s Settings app. Please confirm all permission requested by LapTimer.

Harry
Image Image Image Image
User avatar
enroscado
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 6
Joined: Sun Mar 31, 2019 4:43 pm

Re: Videos missing - can't add them either

Post by enroscado » Tue Apr 02, 2019 9:33 pm

Permissions are enabled to 'Read and Write'.
User avatar
Harry
Site Admin
Site Admin
Posts: 9489
Joined: Sun Sep 12, 2010 10:32 am
Location: Siegum, Germany
Contact:

Re: Videos missing - can't add them either

Post by Harry » Tue Apr 02, 2019 10:19 pm

Do you have a section named “Camera Roll” in Video List?

Harry
Image Image Image Image
User avatar
enroscado
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 6
Joined: Sun Mar 31, 2019 4:43 pm

Re: Videos missing - can't add them either

Post by enroscado » Sat Apr 06, 2019 4:03 pm

Yes, I do. Under it are all the videos of my camera roll, but not the videos of the sessions, even though I can see and play them through the photos app.

Would it help if I post screenshot? What other info can I give you?
User avatar
Harry
Site Admin
Site Admin
Posts: 9489
Joined: Sun Sep 12, 2010 10:32 am
Location: Siegum, Germany
Contact:

Re: Videos missing - can't add them either

Post by Harry » Sat Apr 06, 2019 4:59 pm

Try rebooting your phone. When filling the camera roll section, LapTimer requests all videos from iOS's photo library. There is not any filtering involved except what the photos app does. Maybe some inconsistency in iOS's media library.

- Harry
Image Image Image Image
User avatar
enroscado
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 6
Joined: Sun Mar 31, 2019 4:43 pm

Re: Videos missing - can't add them either

Post by enroscado » Sun Apr 07, 2019 6:19 am

Rebooted, still nothing.

One thing to highlight again: The videos recorded by the gopro, were added later to the media library (in case that makes a difference).

If the above doesn't change anything: Is there a way to do it manually?

Thanks!
User avatar
Harry
Site Admin
Site Admin
Posts: 9489
Joined: Sun Sep 12, 2010 10:32 am
Location: Siegum, Germany
Contact:

Re: Videos missing - can't add them either

Post by Harry » Sun Apr 07, 2019 6:46 am

You can try to add the videos directly into LapTimer’s data area. To do this, use iTunes File Sharing: connect the phone to your PC, start iTunes, select the phone, select File Sharing from the left, select LapTimer, and drop the video into the data folder (where all the .pdb files are).

Harry
Image Image Image Image
Post Reply