Page 1 of 2

Overylay not exporting with GoPro 7 video

Posted: Mon Jan 28, 2019 9:10 pm
by paranoidroid
I imported a synced GoPro 7 video in iOS and when I go to export the overlay is not visible only the lap footage. This is with the overlay options checked. Preview shows the overlay fine. Exporting the built in phone video shows the overlay file. I tried on my iPhone Xs and iPad Pro.

Would love some help here.

Re: Overylay not exporting with GoPro 7 video

Posted: Tue Jan 29, 2019 12:35 pm
by Harry
There is a problem with lap / video synchronization for your video. You can see that Lap #1's end matches the video's end (Joint End, Master) while the Lap #2's end is in front of it? This cannot be correct. To fix, select Lap #2 in the screen shown, in Overlay Synchronization, adjust the sync point using the blue arrow by one hundreds and press Set. LapTimer will ask you whether you want to apply this change to the full Session. Confirm YES. Verify the lap reference information is sound afterwards and try again.

- Harry

Re: Overylay not exporting with GoPro 7 video

Posted: Tue Mar 12, 2019 2:00 am
by Tiago Macedo de
I am facing the same issue. On the video preview I can see the overlay, but after export the overlay to the phone camera roll, the overlay is not visible. So can someone help me on that?
See below some screen shots:

Re: Overylay not exporting with GoPro 7 video

Posted: Wed Mar 13, 2019 1:49 am
by Tiago Macedo de
Here is the screen shot of the overlay on the app

Re: Overylay not exporting with GoPro 7 video

Posted: Fri Mar 15, 2019 12:57 am
by Tiago Macedo de
Hi Herry,
Any update on my issue?
Thanks!

Re: Overylay not exporting with GoPro 7 video

Posted: Sun Mar 17, 2019 3:20 pm
by Harry
Oh, sorry, I missed that...
Are you starting the export from Video Details? Please try to start from any particular lap (i.e. from Lap List ‣ a lap ‣ Video / Export) instead. Export a one lap long section first.

- Harry

Re: Overylay not exporting with GoPro 7 video

Posted: Mon Mar 18, 2019 5:25 am
by Tiago Macedo de
Harry wrote:
Sun Mar 17, 2019 3:20 pm
Oh, sorry, I missed that...
Are you starting the export from Video Details? Please try to start from any particular lap (i.e. from Lap List ‣ a lap ‣ Video / Export) instead. Export a one lap long section first.

- Harry
Hi Herry,
I did that, but I sill not see the overlay.
Is it an issue with the GoPro Hero 7? I say that, because I see many people on the forum using the Hero 7 with the same issue.

Thanks!

Re: Overylay not exporting with GoPro 7 video

Posted: Mon Mar 18, 2019 8:24 am
by Harry
Forums are always full of issue descriptions. But I think yours is unique. As you have a video already, the HERO 7 is not the problem.

Please be precise and detailed for the following tests.

1) select a lap from Lap List
2) make sure it shows a valid track plot in the Data Recordings ‣ Preview row
3) make sure it shows a video thumbnail in the Video ‣ Preview row
4) in case it shows the video's type as "Overlaid", press the Revert or Original button shown below the video
5) press Export in the Video section now
6) create a snapshot of the Overlay Configuration screen you see now and post it here
7) press Overlay to export a new overlaid video
8) back in the lap details view, the type of video should have changed to "Overlaid" now with buttons "Play" and "Revert"/"Original" below
9) press "Play" and see if you get an overlaid video shown

Walk through this steps. In case anything happens that is not in line with the description, let me know. If anything doesn't work as described, let me know what exactly is different and what happens instead.

- Harry

Re: Overylay not exporting with GoPro 7 video

Posted: Wed Mar 20, 2019 1:00 am
by Tiago Macedo de
Harry wrote:
Mon Mar 18, 2019 8:24 am
Forums are always full of issue descriptions. But I think yours is unique. As you have a video already, the HERO 7 is not the problem.

Please be precise and detailed for the following tests.

1) select a lap from Lap List
2) make sure it shows a valid track plot in the Data Recordings ‣ Preview row
3) make sure it shows a video thumbnail in the Video ‣ Preview row
4) in case it shows the video's type as "Overlaid", press the Revert or Original button shown below the video
5) press Export in the Video section now
6) create a snapshot of the Overlay Configuration screen you see now and post it here
7) press Overlay to export a new overlaid video
8) back in the lap details view, the type of video should have changed to "Overlaid" now with buttons "Play" and "Revert"/"Original" below
9) press "Play" and see if you get an overlaid video shown

Walk through this steps. In case anything happens that is not in line with the description, let me know. If anything doesn't work as described, let me know what exactly is different and what happens instead.

- Harry
Hi Herry,
I did exactly what you said, but did not work. The type of video changed to “Overlaid” and with the buttons “Play” and “Revert”.
See below the screenshot from the overlay configuration:

What’s your thoughts?

Thanks

Re: Overylay not exporting with GoPro 7 video

Posted: Wed Mar 20, 2019 8:09 am
by Harry
Well, if you checked for all the items that they behaved / showed up precisely as described (except #9), I probably need to step through this items myself. To do this, export the single lap you selected in step #1 to .hlptrl and send it to Harry@gps-laptimer.de. In addition store the HERO7 video on some server space where I can download it (Dropbox sharing or similar). You can't use youtube, because your video will not be stored 1:1 here. It needs to be some file service.

- Harry