Page 1 of 2

iOS 12 and strange behaviour

Posted: Tue Sep 18, 2018 5:37 pm
by Sonertial
I upgraded my iPhone 7 to iOS 12 today. I am not sure if it is related but I got very unexpected behaviour.

I started a Recording manually at work, and drove homewards. No lap was triggered as I crossed the start finish line. I thought I must not have had my Work to Home track loaded and thought, no worries, I'll sync the lap up with the video later. The timing continued in the live overlay (I run in Video Preview mode because it's more visible for half blind people like me) and a video was being recorded.

I crossed the Finish line, expecting nothing to happen, and tapped Stop a few seconds later. The Voice time announcement said something confusing. "Zero minutes, Eight point Zero Zero seconds. I wasn't really listening, so didn't react to anything beyond the lucky even .00 time.

Now, I see that a video was recorded, of my complete trip home. No problem.
I checked and saw that the Work to Home track was active - that's odd, it should have auto triggered a lap start when I crossed the Start line. Like it has always done before.

Now the problem. The only data that was recorded was between when I crossed the FINISH line and until I tapped Stop. So 8 seconds of data. In other words, the lap started when I crossed the finish line, and the manual recording I started before I crossed the Start line is not there.

Not sure what to make of this, if it's an iOS 12 issue or not. I am out of the country for a few days so I won't be able to test this further until next week, but just a heads up.

Re: iOS 12 and strange behaviour

Posted: Sun Sep 23, 2018 8:06 am
by Sonertial
HLT is not working at all since I upgraded to iOS 12.

I have tried:
Restarting the App.
Restarting the phone.
Deleting all Laps.
Deleting all Tracks and making one new Start/Stop trigger, with a direction set.
Manually starting recording before crossing the Start/Finish line.
Automatically Starting recording by crossing the Start/Finish line.

When trying to record, Laptimer is only very erratically started by Start/Stop triggers, usually not at all. It is not stopped by triggers. When manually stopping the recording, the time numbers are nonsense. For example, I started recording manually about 300m before the S/F. Timing did not start, but I drove past and continued around the "track". I stopped timing after about 90 seconds:
IMG_3485[1].png (397.25 KiB) Viewed 873 times
but the time recorded was only 7.7secs. These images were screenshot withing about 20 seconds of each other.
IMG_3486[1].png (418.16 KiB) Viewed 873 times
Other observations which may be relevant:
I got impression the update rate of the overlay in the video preview (Time, speed, RPM etc) dropped dramatically when crossing the Start Line. This is hard to verify though, since I am usually driving and only glancing briefly at the screen.
Another impression is that the iPhone is using much more battery than normal when using the app.
In the map view, the dots showing recent fixes are flickering.
There is a new screen time feature running in iOS12. I had not turned this off.

I have not tried, but will this afternoon:
Recording without video.
Recording using a different screen than the Video Preview (I always use Video Preview because it is easier to see when wearing driving glasses).
Turning off the new "Screen Time" monitoring that came with the new iOS.
Any suggestions? Logging parameters?

There is possibly some issue with the direction setting on custom tracks. I am 100%, definitely, absolutely setting a direction on these trigger POIs. I never skip this step. But I wonder if this custom set direction is being ignored by the app for non certified tracks? Or perhaps when starting recording Manually?
Between the above pictures, the start finish line was actually crossed (it's the pedestrian crossing visible in the first one), but the direction is set to be 180° to the direction I was travelling in these images. No lap was triggered, but the time of 7.7 seconds might be about right for the time since passing the S/F, - in the opposite direction. This kind of matches my impression that some of the false trigger issues I have been getting seem to be ignoring the direction when the GPS fixes wander around in bad GPS conditions.

Re: iOS 12 and strange behaviour

Posted: Sun Sep 23, 2018 8:19 am
by Harry
Please check your Expert Settings "Allow Low Speeds" and "Storage Rate" and let me know. Any other non-standard expert settings?
There is a problem with lap time calculations currently. It occurs intermittent and will be fixed in 22.0.5. I will check effects from manual operation too. But all of this is not iOS 12 specific. I have not received other reports on missed triggers with iOS12 so far, so probability is high it is a problem with your configuration.

- Harry

Re: iOS 12 and strange behaviour

Posted: Sun Sep 23, 2018 8:26 am
by Sonertial
Damn I deleted my earlier reply somehow.

Allow Low Speeds is OFF.
Storage Rate is "GPS rate"

All other settings are default except the timings and Speed multiplier (1.04)
These settings are fairly well tested before iOS12
IMG_3489[1].png (68.69 KiB) Viewed 870 times

Re: iOS 12 and strange behaviour

Posted: Sun Sep 23, 2018 8:39 am
by Sonertial
Ah, I may have also changed the accelerometer Update rate to 30, and noise reduction to 0.3 (can't remember what default is)

Re: iOS 12 and strange behaviour

Posted: Tue Sep 25, 2018 8:46 am
by Sonertial
Another observation on both my iPhone 7 and my colleagues iPhone 7+. Times are being rounded, I do not recall this ever being the case before.

When manually starting timing, in the Timer view, just sitting in the office, stopping it very often (not always, but 95%) results in a time rounded to the nearest second. Usually close to the actual time that the button was tapped, but sometimes completely incorrect.

This also occurs in the Video Preview mode, but much worse. Like I recorded a 6:30minute drive this morning and when I stopped it, the value recorded was 0:12.50. After a 50 second recording, the value was 0:00.00.

I tested and got the same rounding issue and incorrect recordings with and without the Kiwi3 and with and without the Dual XGPS160.

Automatic triggering is not working at all.

I have tried the following:

deleted all videos on the phone
deleted all laps, all tracks
reinstalled the app
re-imported my Car by opening a *.hlptrz file then deleted all those laps that came with it.
All settings are default. (Apart from my car definition).

The manual timing issues remain . I stopped a manual recording after about 50 seconds, the time recorded was 0:18.00. Doing it again, the times are almost always being rounded to a nearest second, but not necessarily the actual second that I tap Stop. Often it is 0:00.00.

In Video Preview mode, when I continuously start and stop recordings at about 5 seconds, the live overlay update rate gets slower and slower, starting at about 5-10 fps and dropping to 0.5 fps. The phone's getting pretty warm, but that might be normal,

I'll continue testing automatic triggering with the fresh installation after work. If no progress I will reset the iPhone completely back to Factory Settings.

Re: iOS 12 and strange behaviour

Posted: Tue Sep 25, 2018 1:23 pm
by Harry
I will re-check manual timing / recording for one of the next bug fix releases. Independent from iOS version, LapTimer v22 will round timing results to the storage rate set. So if you are using the internal GPS and have the Expert Setting on storage rate keep (GPS rate), you will get this effect of 1s precision.

- Harry

Re: iOS 12 and strange behaviour

Posted: Tue Sep 25, 2018 4:17 pm
by Sonertial
I am getting 1 second resolution with 5Hz using internal and External Dual GPS. I get 0.1 second resolution with 10Hz + Dual GPS, 1 second with Internal-

Re: iOS 12 and strange behaviour

Posted: Tue Sep 25, 2018 4:39 pm
by Harry
Ok, please give some time, I will check.
Version 22.1.0 has been submitted already, so I expect this to be addressed in 22.1.1


Re: iOS 12 and strange behaviour

Posted: Wed Sep 26, 2018 6:49 am
by Sonertial
I completely reset my iPhone last night, a complete erase. TLDR, I still can't trigger laps.

All settings are completely default except where noted.

I imported some some laps to get my car details correct.
I set Storage rate to 10Hz

I tried repeatedly to start timing this morning on the way to work. In with Manual triggering active, I could not get it to trigger at the POI all. I tested with the Dual XGPS160, then with it turned off.

Then I turned OFF Manual triggering, but started the video manually. No lap was triggered, neither Start nor Stop, but there was some garbage data and an incorrect time stored. This was with internal GPS.

I'd request a reconsideration of the Manual timing resolution by the way. Does this mean that videos recorded with no POI triggers will require manual syncing? I use HLT to record interesting roads when on holiday for example, and I like having the overlay.