trackbike: help troubleshooting HLT GP w/external GPS over BT

Help on issues you run into with LapTimer; in case you have a question on how to use LapTimer, use the forum "Using LapTimer" instead
miked187
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 5
Joined: Tue Sep 08, 2015 8:33 pm
Location: California

trackbike: help troubleshooting HLT GP w/external GPS over BT

Postby miked187 » Fri Jun 22, 2018 2:19 am

running HLT GP on android, version 21.2, have a Reyax725 connected over BT running at 10hz on my trackbike. I have no idea where to start trying to troubleshoot this, and so no idea of what info to add here to help you help me.

I have the phone mounted on the triple clamp, GPS assy is on a fairly flat surface with a clear view of the sky above it, left metal handlebar does go back and forth over the top as I ride the track. Phone and GPS assy are within a foot of each other. The GPS sync's with the phone w/out issue, HLT GPS screen shows the HC-06 BT module is connected with 9+ satellites when I last looked.

I ride the track and the times on the timing screen jump all over the place in what appears to be random nonsensical numbers, never seeming to go over 30-35 seconds and jumping back down to a low of 5. I can put a camera on it this weekend if it will help to see both the setup and the timing screen.

Now I go to review the laps and nothing from the dates last Monday the 18th when I rode on that track are available in the lap list.

Let me know what other info I can provide, my riding is suffering without being able to geek out over the data lol. And this is frustrating along with not have a place to start in on troubleshooting. Thanks in advance

Mike


03 R1 track bike, 04 FTR 125 shifter kart, a garage full of motorsports projects
User avatar
Harry
Site Admin
Site Admin
Posts: 8989
Joined: Sun Sep 12, 2010 10:32 am
Location: Siegum, Germany
Has thanked: 98 times
Been thanked: 378 times
Contact:

Re: trackbike: help troubleshooting HLT GP w/external GPS over BT

Postby Harry » Sun Jun 24, 2018 4:33 pm

Please follow instructions in viewtopic.php?f=39&t=1933 to create a trace log. Please select the GPS Sensor trace class only. This is probably some incompatibility of NMEA messages.

- Harry


Image Image Image Image
miked187
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 5
Joined: Tue Sep 08, 2015 8:33 pm
Location: California

Re: trackbike: help troubleshooting HLT GP w/external GPS over BT

Postby miked187 » Mon Jun 25, 2018 4:44 pm

I'll be back on the track in 3 weeks and will generate the log then . Thanks


03 R1 track bike, 04 FTR 125 shifter kart, a garage full of motorsports projects
User avatar
Harry
Site Admin
Site Admin
Posts: 8989
Joined: Sun Sep 12, 2010 10:32 am
Location: Siegum, Germany
Has thanked: 98 times
Been thanked: 378 times
Contact:

Re: trackbike: help troubleshooting HLT GP w/external GPS over BT

Postby Harry » Mon Jun 25, 2018 6:28 pm

miked187 wrote:I'll be back on the track in 3 weeks and will generate the log then . Thanks

No need to use your valuable time on track. You can create this log while in front of the house. You do not even need to drive. Just bring up LapTimer and make sure your get GPS readings from your external device in Sensor List or Analysis ‣ Realtime ‣ GPS while logging.

- Harry


Image Image Image Image
miked187
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 5
Joined: Tue Sep 08, 2015 8:33 pm
Location: California

Re: trackbike: help troubleshooting HLT GP w/external GPS over BT

Postby miked187 » Fri Jun 29, 2018 10:24 am

You're right, no need to be on the bike to gen a log. But I'm out of the country till mid July, will get that log posted when I get back in


03 R1 track bike, 04 FTR 125 shifter kart, a garage full of motorsports projects
miked187
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 5
Joined: Tue Sep 08, 2015 8:33 pm
Location: California

Re: trackbike: help troubleshooting HLT GP w/external GPS over BT

Postby miked187 » Wed Jul 11, 2018 8:36 pm

log sent


03 R1 track bike, 04 FTR 125 shifter kart, a garage full of motorsports projects
User avatar
Harry
Site Admin
Site Admin
Posts: 8989
Joined: Sun Sep 12, 2010 10:32 am
Location: Siegum, Germany
Has thanked: 98 times
Been thanked: 378 times
Contact:

Re: trackbike: help troubleshooting HLT GP w/external GPS over BT

Postby Harry » Thu Jul 12, 2018 9:44 am

Not sure this is the full story, but I see at least a problem with the NMEA sentence "VTG"

Code: Select all

$GPVTG,,T,,M,0.067,N,0.125,K,D*21

where something like

Code: Select all

$GPVTG,0.0,T,359.6,M,0.0,N,0.0,K*47

is expected.

LapTimer should probably handle this gratefully, but it doesn't currently.

It looks like the log has been created while standing still. Well possible, VTG works once you are moving (VTG should deliver a driving direction - which is unknown while standing still). To find the actual problem with jumping numbers required VTG to work. Can you please try to create another log while driving? Thanks.

- Harry


Image Image Image Image
miked187
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 5
Joined: Tue Sep 08, 2015 8:33 pm
Location: California

Re: trackbike: help troubleshooting HLT GP w/external GPS over BT

Postby miked187 » Thu Jul 12, 2018 12:19 pm

yes, I left the gps just sitting on a table for a moment. Will gen another log while on the move later this morning and get it to you


03 R1 track bike, 04 FTR 125 shifter kart, a garage full of motorsports projects

Return to “Trouble Shooting”

Who is online

Users browsing this forum: Harry and 1 guest