HLT doesn't record acceleration data when using external GPS

Help on issues you run into with LapTimer; in case you have a question on how to use LapTimer, use the forum "Using LapTimer" instead
steved0x
20 or more Posts ★★★
20 or more Posts ★★★
Posts: 20
Joined: Mon Jul 25, 2016 3:07 pm
Has thanked: 1 time
Been thanked: 1 time

Re: HLT doesn't record acceleration data when using external GPS

Postby steved0x » Sun Feb 04, 2018 7:34 pm

Am using presets and the phone is mounted on the windshield. Oddly I do see accel data on the charts for the lap I exported, this screenshot:

https://drive.google.com/file/d/1ipF94y ... p=drivesdk

I'm good with recalculating but wanted to provide this extra information.


ckowalc
20 or more Posts ★★★
20 or more Posts ★★★
Posts: 67
Joined: Thu May 14, 2015 7:33 pm
Has thanked: 5 times

Re: HLT doesn't record acceleration data when using external GPS

Postby ckowalc » Tue Feb 13, 2018 4:04 am

I've been having a similar issue for 1.5+ years. Sometimes the acceleration graph looks good, sometimes it looks like randoms cutouts in the data and sometimes there are like 5 points. Kind of annoying.

Using Qstarz 818XT 10 Hz, Android

Here is my post from back then:
viewtopic.php?f=8&t=4059&p=21022#p21022


steved0x
20 or more Posts ★★★
20 or more Posts ★★★
Posts: 20
Joined: Mon Jul 25, 2016 3:07 pm
Has thanked: 1 time
Been thanked: 1 time

Re: HLT doesn't record acceleration data when using external GPS

Postby steved0x » Wed Feb 14, 2018 9:49 pm

Yes that is very similar to mine, except mine just started. The Accel data and speed on the video at 5hz is the sweet spot for me, I like to watch it in between runs and it helps me see places when I am not maximizing a corner, so I miss it a lot. It sounds like the new Spring 2018 updates will decouple the data rate for accelerometers and things from the GPS update rate which will be pretty cool.


ereynold60
20 or more Posts ★★★
20 or more Posts ★★★
Posts: 47
Joined: Fri Mar 13, 2015 9:31 pm
Been thanked: 1 time

Re: HLT doesn't record acceleration data when using external GPS

Postby ereynold60 » Tue Apr 17, 2018 10:31 pm

I'm experiencing this same behavior... v21.2. I've always used a Dual Skypro external GPD... acceleration data was fine last May 2017 (v21.0)... Now I'm not getting any G-forces recorded. Phone is mounted solidly and using Right-hand drive preset...

Is this now truly broken until v22 ???

Is there any way to go back to v21.0 ???


User avatar
Harry
Site Admin
Site Admin
Posts: 8793
Joined: Sun Sep 12, 2010 10:32 am
Location: Siegum, Germany
Has thanked: 97 times
Been thanked: 362 times
Contact:

Re: HLT doesn't record acceleration data when using external GPS

Postby Harry » Wed Apr 18, 2018 7:46 am

You can generate acceleration data from GPS:

Lap List ‣ any lap ‣ Data Recordings / Recalculate ‣ Acceleration

We will check this during v22 beta.

- Harry


Image Image Image Image
ereynold60
20 or more Posts ★★★
20 or more Posts ★★★
Posts: 47
Joined: Fri Mar 13, 2015 9:31 pm
Been thanked: 1 time

Re: HLT doesn't record acceleration data when using external GPS

Postby ereynold60 » Wed Apr 18, 2018 1:05 pm

V21.2 introduced anew expert setting for "External GPS Delay" with a default of 0.7 seconds.... previous versions only had one GPS delay which I had set at 1.5 seconds... is this the cause of missing acceleration data? What delay was used on previous version for external GPS... was it 1.5 seconds?

Also, I can see recalculating longitudinal acceleration from GPS, but how good is lateral acceleration calculated from GPS ???


ereynold60
20 or more Posts ★★★
20 or more Posts ★★★
Posts: 47
Joined: Fri Mar 13, 2015 9:31 pm
Been thanked: 1 time

Re: HLT doesn't record acceleration data when using external GPS

Postby ereynold60 » Wed Apr 18, 2018 10:00 pm

Harry - I feel fairly certain this is a software bug introduced with V21.2, sorry to say. I set the External GPS Delay to 1.5 seconds to match previous expert setting, but no acceleration data is recorded. I also tried changing the Accelerometer rate to 60Hz (up from 30), but no effect.

Then I noticed that I only had exactly 6 acceleration data points per lap on my "test circuit"... This "circuit has 3 sectors", and acceleration data is ONLY recorded at sector splits and Start/Finish... one "x" and one "y" value... i.e. 6.

Perhaps this can help you find this bug... as it appears to be a logic error with external GPS, where acceleration data is ONLY recorded during a GPS "action trigger"... i.e. SF line or sector.


User avatar
Harry
Site Admin
Site Admin
Posts: 8793
Joined: Sun Sep 12, 2010 10:32 am
Location: Siegum, Germany
Has thanked: 97 times
Been thanked: 362 times
Contact:

Re: HLT doesn't record acceleration data when using external GPS

Postby Harry » Wed Apr 18, 2018 10:29 pm

Please use the workaround described for now. v22 is in development and the sensor fusion part has been rewritten. I will not return to v21 to analyze or fix something that's obsolete. BTW, changing delays to non standard values can break v21 fusion. Defaults are 0.7 for external GPS sensors, and 0.5 for acceleration.

- Harry


Image Image Image Image
ereynold60
20 or more Posts ★★★
20 or more Posts ★★★
Posts: 47
Joined: Fri Mar 13, 2015 9:31 pm
Been thanked: 1 time

Re: HLT doesn't record acceleration data when using external GPS

Postby ereynold60 » Thu Apr 19, 2018 7:16 pm

Harry - I understand you are in development of new sensor fusion for this area. The workaround of recalculating acceleration data from GPS doesn't produce a truly accurate result - its fairly jumpy / spiky even with strong smoothing.

I have a track event next weekend and would like to revert to v21.0 which worked fine for me, however the Android Play Store provides no method for going back to v21.0 or removing an update.

Can you provide the v21.0 APK in the interim? perhaps via Play Store, or email... is there any other way of going back to v21.0 ???

I do not share or provide copies of licensed software, as I respect software develop rights.... Thanks for consideration.
Last edited by ereynold60 on Fri Apr 20, 2018 9:16 pm, edited 1 time in total.


User avatar
Harry
Site Admin
Site Admin
Posts: 8793
Joined: Sun Sep 12, 2010 10:32 am
Location: Siegum, Germany
Has thanked: 97 times
Been thanked: 362 times
Contact:

Re: HLT doesn't record acceleration data when using external GPS

Postby Harry » Thu Apr 19, 2018 7:38 pm

Not possible, I‘m sorry.
You may try configuring your Qstarz to 5 Hz - smoothing calculated data is easier for lower update rates.

Harry


Image Image Image Image

Return to “Trouble Shooting”

Who is online

Users browsing this forum: No registered users and 3 guests