media decoder error

Help on issues you run into with LapTimer; in case you have a question on how to use LapTimer, use the forum "Using LapTimer" instead
Post Reply
jwmelvin
20 or more Posts ★★★
20 or more Posts ★★★
Posts: 53
Joined: Fri Oct 18, 2013 1:28 pm

media decoder error

Post by jwmelvin »

I'm trying to sync an external video, loaded through iTunes. It works a few times and then a popup window states "Cannot Decode. The decoder required for this media is busy." I have quit all other apps and restarted HLT. That worked at one point but then I had to reboot the phone in order for HLT to play the video again. Video is a .mov file and played a number of times correctly.

iOS 11.0.3
iPhone 6S
HLT GP v21.1
User avatar
Harry
Site Admin
Site Admin
Posts: 10002
Joined: Sun Sep 12, 2010 10:32 am
Location: Siegum, Germany
Contact:

Re: media decoder error

Post by Harry »

Hi,

This is probably a remaining issue with iOS11. It looks like LapTimer accesses iOS's media library in a way it doesn't like since iOS11. Can you give me some more information:

- Which cam has been used to record the video?
- Where is it stored - in Photos or in LapTimer's own data area?
- Do you have a PiP for the overlay? I.e. is there a second video assigned to the lap or do you have a reference lap with video attached?
- Does this problem occur for single lap overlays or for multiple laps only?

Thanks, Harry
Image Image Image Image
jwmelvin
20 or more Posts ★★★
20 or more Posts ★★★
Posts: 53
Joined: Fri Oct 18, 2013 1:28 pm

Re: media decoder error

Post by jwmelvin »

The camera is an Eken H9. I put the video segments together with OS X, saving from the Quicktime player.
The video is stored in LapTimer's own data area, using iTunes file transfer.
I am not using a second video or a reference lap.
The problem occurs universally, in that when it occurs I am unable to play a video from the Video List, or preview a video in a single lap. When I originally synced the video, I did select to set the timing for the full session. I have not exported any overlays yet.
User avatar
Harry
Site Admin
Site Admin
Posts: 10002
Joined: Sun Sep 12, 2010 10:32 am
Location: Siegum, Germany
Contact:

Re: media decoder error

Post by Harry »

The problem seems to be that there is another decoding process accessing the file already. When LapTimer starts decoding the file in addition, the error occurs. Well possible it is LapTimer itself that does the second access, but I'm not sure. So any reproducible sequence would be helpful.

- Harry
Image Image Image Image
jwmelvin
20 or more Posts ★★★
20 or more Posts ★★★
Posts: 53
Joined: Fri Oct 18, 2013 1:28 pm

Re: media decoder error

Post by jwmelvin »

I can't quite figure out the key to making it reproducible but I'm quite sure nothing else besides HLT is trying to access the file. It seems to be okay if I delete the video link and relink it, at least for a while.
slgibelp
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 2
Joined: Sun Apr 29, 2018 10:47 pm

Re: media decoder error

Post by slgibelp »

I try to watch lap videos in HLT, but frequently get message "Cannot DECODE" "the decoder required for this media is busy." Sometimes video will run, but most times I get the error message. I did upgrade to IOS11. I am using my iPhone camera for videos. Any help would be greatly appreciated.
User avatar
Harry
Site Admin
Site Admin
Posts: 10002
Joined: Sun Sep 12, 2010 10:32 am
Location: Siegum, Germany
Contact:

Re: media decoder error

Post by Harry »

This occurs since iOS11. I think I have fixed that for v22 but need to verify during beta.

- Harry
Image Image Image Image
Djsteviec
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 1
Joined: Sun Sep 02, 2018 3:49 am

Re: media decoder error

Post by Djsteviec »

I am having this issue with my iPhone on 11.4.1
Post Reply