All laps lost after sytem crash

Help on issues you run into with LapTimer; in case you have a question on how to use LapTimer, use the forum "Using LapTimer" instead
Post Reply
jarobs
20 or more Posts ★★★
20 or more Posts ★★★
Posts: 53
Joined: Mon Jul 20, 2015 12:11 pm

All laps lost after sytem crash

Post by jarobs » Tue Jun 20, 2017 1:21 pm

Dear HLT team,

HLT crashed while recording because the phone run out of space. After restarting all historical laps, loaded tracks and car info was lost.
Is it still somewhere on the phone and is there any way to recover the information?

Best Jarob
User avatar
Harry
Site Admin
Site Admin
Posts: 9583
Joined: Sun Sep 12, 2010 10:32 am
Location: Siegum, Germany
Contact:

Re: All laps lost after sytem crash

Post by Harry » Tue Jun 20, 2017 2:50 pm

Yes, as long as you do not uninstall the app, you can most probably recover your historic data.

1) Start with freeing up memory, make sure you have 1 GB or more.
2) Goto LapTimer ‣ Administration ‣ Databases
3) Select the last automatic backup and long press (Android) or swipe (iOS) this entry.
4) Select the restore option. Once completed successfully, run Check Data until is is shown 0 problems.
5) In case 4) fails, repeat with the second best candidate and go back to 4)

- Harry
Image Image Image Image
jp.fox
10 or more Posts ★
10 or more Posts ★
Posts: 13
Joined: Sun Oct 30, 2016 8:04 pm

Re: All laps lost after sytem crash

Post by jp.fox » Tue Sep 03, 2019 7:22 am

Hi Harry, how long would you expect this process to take on a Samsung S8 with 1900 laps? The time remaining seems to go up and up and up and it must have been going at least 12 hours before it stopped at some point overnight. I didn't see an error message but I don't have anything back so presuming there was an error of some sort. I'm currently trying an older back up file with 1743 laps and the time remaining is slowly creeping up again.
User avatar
Harry
Site Admin
Site Admin
Posts: 9583
Joined: Sun Sep 12, 2010 10:32 am
Location: Siegum, Germany
Contact:

Re: All laps lost after sytem crash

Post by Harry » Tue Sep 03, 2019 7:30 am

Hello,

Both the number of laps and the data available and missing is going into the complexity of recovery. I had recoveries running for 24 hours but got data successfully in the end. But I have seen configuration that were not recoverably (in terms of complexity, making the time to completion explode) too. I keep my fingers cross. Trying older backups in case late ones do not work is a good approach.

- Harry
Image Image Image Image
jp.fox
10 or more Posts ★
10 or more Posts ★
Posts: 13
Joined: Sun Oct 30, 2016 8:04 pm

Re: All laps lost after sytem crash

Post by jp.fox » Tue Sep 03, 2019 12:33 pm

Thanks Harry, the 1743 failed. I then tried the oldest file with a lot less laps and it says it completed but I still don't have any laps. Currently trying a 1490 lap option but not holding out much hope to be honest :(

Is there anything I can do if this doesn't work? Sad to think that all of those lap times are lost because I wrongly selected internal memory rather than SD card when moving photos to a new folder :shock:
User avatar
Harry
Site Admin
Site Admin
Posts: 9583
Joined: Sun Sep 12, 2010 10:32 am
Location: Siegum, Germany
Contact:

Re: All laps lost after sytem crash

Post by Harry » Tue Sep 03, 2019 1:05 pm

I assume the memory shortage is just the trigger to reveal the database had some corruption. Check Data is ran automatically when a database is not closed properly and LapTimer starts up afterwards. As long as no Check Data is ran, the problem is not becoming visible. have you created a backup to HLPTRL lately? This allows the full restore.

As a last option, you can export the raw database for you one of the latest databases and send it to me (Harry@gps-laptimer.de). Do not forget to add a note on this thread. This is a manual operation, so it will take some time until I come back. As a minimum, I can extract the list of lap times (without detail data) from this.

- Harry
Image Image Image Image
jp.fox
10 or more Posts ★
10 or more Posts ★
Posts: 13
Joined: Sun Oct 30, 2016 8:04 pm

Re: All laps lost after sytem crash

Post by jp.fox » Tue Sep 03, 2019 1:47 pm

Harry wrote:
Tue Sep 03, 2019 1:05 pm
have you created a backup to HLPTRL lately? This allows the full restore.
Sadly not since I moved to this phone at the start of last year so probably lost 40 days on track, I will be doing it after every day in future!

Harry wrote:
Tue Sep 03, 2019 1:05 pm
As a last option, you can export the raw database for you one of the latest databases and send it to me (Harry@gps-laptimer.de). Do not forget to add a note on this thread. This is a manual operation, so it will take some time until I come back. As a minimum, I can extract the list of lap times (without detail data) from this.
Thanks, I'll see how I get on with this attempt to restore (c. 5 hours left) and let you know, appreciate the offer!
jp.fox
10 or more Posts ★
10 or more Posts ★
Posts: 13
Joined: Sun Oct 30, 2016 8:04 pm

Re: All laps lost after sytem crash

Post by jp.fox » Tue Sep 03, 2019 5:10 pm

All laps recovered and back ups created immediately! Thanks for your help :D
User avatar
Harry
Site Admin
Site Admin
Posts: 9583
Joined: Sun Sep 12, 2010 10:32 am
Location: Siegum, Germany
Contact:

Re: All laps lost after sytem crash

Post by Harry » Wed Sep 04, 2019 7:12 am

Good!
Image Image Image Image
Post Reply