Iphone 4 GPS signal constant on red; 0Hz rate....

Help on issues you run into with LapTimer; in case you have a question on how to use LapTimer, use the forum "Using LapTimer" instead
Post Reply
Caprimaniac
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 7
Joined: Mon Jun 15, 2015 11:00 pm

Iphone 4 GPS signal constant on red; 0Hz rate....

Post by Caprimaniac » Mon Jun 15, 2015 11:12 pm

Hello all.

I purchased Harry's laptimer as soon as I got me Iphone some years back. The petrollhead edition. I have done all updates. The latest one today, actually-

It worked well for a couple of years. Then, two years back, it started having problems. Not finding POI's and therefore no laptimes... Well, I've been thinking about this and I've triede different Things, like updating my phone service. Even tried updating to IOS8 today- figuring the Iphone4 cannot get the IOS8....

Anyways. I went for a walk today after I treied using the app in the car without succes.

Opened the laptimer. ent to the GPS panel in the sensor list.

Walk lasted 30 mins in open air. I never saw anything but red on the GPS signal. 0Hz sampling rate.
On the skymap I see no satelites...


Please help!!!!
What is wrong????
User avatar
Harry
Site Admin
Site Admin
Posts: 9583
Joined: Sun Sep 12, 2010 10:32 am
Location: Siegum, Germany
Contact:

Re: Iphone 4 GPS signal constant on red; 0Hz rate....

Post by Harry » Tue Jun 16, 2015 7:04 am

This means LapTimer doesn't get a valid position from GPS. iOS actually has two sources for position: triangulated mobile networks, or data from the GPS sensor built in. While many apps will use the former to show a rough position, LapTimer uses the later only (because triangulated positions are not usable on track).

So the problem may actually be an hardware issue with your GPS you didn't observe for other apps as they use triangulated positions...

Try using some other app like MotionX GPS or Harry's GPS Buddy and check if you get the same effect.

If yes, exchange hardware or add an external GPS.

Satellite View will not show you sats for the internal GPS ever, it is for external GPSes only. So this part is ok.

Harry
Image Image Image Image
Caprimaniac
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 7
Joined: Mon Jun 15, 2015 11:00 pm

Re: Iphone 4 GPS signal constant on red; 0Hz rate....

Post by Caprimaniac » Wed Jun 17, 2015 10:50 am

Yes, the result is the same With the GPS buddy.

Are you saying I will have to buy a New iphone to use Your app? Hardware is what you said....

This is VERY strange, as it has previously worked well With internal iphone4 GPS.

One example; on a local autocross track I put up POI's and defined track. Worked well. On later visits there has been nothing but trouble. It looks like the system just stopped wotking properly.

I think it is a bug/ problem with laptimer/ iphone4 /IOS7.

Have done some googeling, but not found any solution yet.

Strange thing there aren't any topics in the forum on this; am I the only one With this problem???? Unless there is some kind of damage in my phone/GPS sensor/ system..... But how could I figure?
User avatar
Harry
Site Admin
Site Admin
Posts: 9583
Joined: Sun Sep 12, 2010 10:32 am
Location: Siegum, Germany
Contact:

Re: Iphone 4 GPS signal constant on red; 0Hz rate....

Post by Harry » Wed Jun 17, 2015 12:32 pm

Yes, you are the only one with this problem... You may recheck if you have enabled location services at all (in iOS ‣ Settings ‣ Location Service), but LapTimer will issue a warning in case it isn't enabled. In case it is enabled and you do not get GPS reception after a few seconds / longest 2 minutes while outside, there is some hardware or iOS base level issue.

- Harry
Image Image Image Image
Caprimaniac
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 7
Joined: Mon Jun 15, 2015 11:00 pm

Re: Iphone 4 GPS signal constant on red; 0Hz rate....

Post by Caprimaniac » Sat Jun 20, 2015 10:10 am

Well.... After alot of hours spent, I have the GPS signal once again up in the yellow and green area...


NO; definately NOT the only one With this issue. It has been persistent in well over a year.
All apps I use for navigation has had the same symptoms....

Did some Google searches. Found a couple of tips. Tried the "easiest" solution: Try going to settings... general... reset... reset location & privacy... then go into settings... general... reset... reset network settings - between the two of them, it should clear any caching of A-GPS data and give you a fresh start.

Couldn't get it to work.

The iphone was wiped and started as a New unit. I installed all apps and Things. However lost all data...

Didnt' work either....


Redid steps above while walking my dog this morning. No effect at first hand. But after connecting to WIFI at home, everything turned out good. I also turned my WIFI off to check, and GPS signal shows up good, and I'm happy.

If it only would last till I need to buy a New phone. Let's hope so.

Tip was found here: http://forums.imore.com/ios-6/253370-gps-problems.html
User avatar
Harry
Site Admin
Site Admin
Posts: 9583
Joined: Sun Sep 12, 2010 10:32 am
Location: Siegum, Germany
Contact:

Re: Iphone 4 GPS signal constant on red; 0Hz rate....

Post by Harry » Sat Jun 20, 2015 10:21 am

I can't speak for the millions of devices out there, you will certainly always find someone with the same or similar sounding issues.

The issue is at least very rare and a strong indicator for some issue with the hardware. What I wanted to say is don't waste time trying to solve this issue on app level, it is iOS or hardware. Anyway, this probably doesn't help you for an older phone, keep my fingers cross it works until you get your hands on a new one.

Harry
Image Image Image Image
Caprimaniac
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 7
Joined: Mon Jun 15, 2015 11:00 pm

Re: Iphone 4 GPS signal constant on red; 0Hz rate....

Post by Caprimaniac » Thu Jun 25, 2015 1:32 pm

Well... It din't last very long. Have not seen "green" GPS- signal more than once after this "fix".

I am tempted to do a fdu (or whatever they Call it)- reinstall of the phone. And also install all apps New, from blank...However, will I have to purchase it once more? Or are there ways around that?

I removed Google maps from the phone. There are still iphone MAPS and a couple of other GPS- based apps, so there's room for conflicts. Here is one that Works without a network; SkiTracks. Will work on GPS only. As you can see, the tracking is not very correct. It seems like it's picking up signal just now and then. Just like Harry's laptimer green in one second- red the NeXT (however last 5 days- only red.....)
Image

And here's one during a car- ride (where Harry's never showed green). Probably no signal during Speed= 0. Than back up....
Image

Can it be due to my Phones tlph network/ operator??? I have no Clue here, so if anyone have any ideas....
rscliofan
20 or more Posts ★★★
20 or more Posts ★★★
Posts: 152
Joined: Tue Jun 12, 2012 12:48 pm

Re: Iphone 4 GPS signal constant on red; 0Hz rate....

Post by rscliofan » Sun Jun 28, 2015 9:58 am

Harry is politely pointing out that it is your device that is more than likely broken. If that is the case which it sounds very much like the case from more than one app not working you will need to 1. Buy a new device 2. Fix the device or 3. Use an external GPS device.

Yes you can wipe your device and set it up as a new device and just redownload it via iTunes without any cost provided you use the same Apple ID. You can then add any iap via the addons again without any additional cost.
Caprimaniac
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 7
Joined: Mon Jun 15, 2015 11:00 pm

Re: Iphone 4 GPS signal constant on red; 0Hz rate....

Post by Caprimaniac » Mon Aug 10, 2015 1:09 pm

You were correct; it has to be broken. I downloaded an app called "GPS status". It showed poor signal, and could not read speed or direction.

However, Compass Works well.... I think what's missing is a good siagnose of the iphones GPS function/ antennae.

Thanks
gplracerx
20 or more Posts ★★★
20 or more Posts ★★★
Posts: 836
Joined: Thu May 03, 2012 5:26 am
Location: Kingsport, TN USA

Re: Iphone 4 GPS signal constant on red; 0Hz rate....

Post by gplracerx » Mon Aug 10, 2015 2:25 pm

The compass and the GPS are different bits of hardware. AFAIK, the GPS in a phone is a single integrated circuit device that includes the antenna. It either works, or it doesn't. There's nothing that can be fixed if it doesn't. Reloading the firmware won't help. It's probably cheaper to buy an external GPS like the Dual XGPS160 than get a new phone.

Given that you did get it to work once, it's probably the not the chip itself, but the connection to the main board. That probably isn't fixable either, or the cost of fixing it would be similar to buying an external GPS.
Post Reply