[SOLVED] OBD WLAN dropping. Using w/Jailbroken ...

Help on issues you run into with LapTimer; in case you have a question on how to use LapTimer, use the forum "Using LapTimer" instead
Gernby
20 or more Posts ★★★
20 or more Posts ★★★
Posts: 21
Joined: Mon Oct 24, 2011 2:26 pm

Re: OBD WLAN dropping. Using w/Jailbroken iPhone4+RoqyBT4+GP

Post by Gernby » Tue Oct 25, 2011 10:28 pm

I just read through the thread to see if anyone has tried moving the location of the iPhone and / or WLAN device around to different parts of the car to see if the issue is related to reflection caused by the car's chassis. I believe the connection might be more stable if the devices were near windows in order to reduce the transmission power that echos around in the passenger compartment.
Gernby
20 or more Posts ★★★
20 or more Posts ★★★
Posts: 21
Joined: Mon Oct 24, 2011 2:26 pm

Re: OBD WLAN dropping. Using w/Jailbroken iPhone4+RoqyBT4+GP

Post by Gernby » Wed Oct 26, 2011 2:18 am

Woo hoo! My PLX Wiki Wifi arrived today unexpectedly, so I hooked it up, and did a quick test around my neighborhood. I was disappointed to see that it had TONS of dropouts using the default settings. Instead of trying all the settings mentioned in this thread (Airplane mode, etc.), I decided to test my suggestion above. I ran the OBDII cable out the window, and wrapped it around the door mirror with the Wiki wifi outside the car. Then I repeated the same test, and BAM ... no more dropouts!

I think the issue is that the "echo" from having 2 Wifi transievers inside a small metal container is causing the signal to interfere with itself.
Gernby
20 or more Posts ★★★
20 or more Posts ★★★
Posts: 21
Joined: Mon Oct 24, 2011 2:26 pm

Re: OBD WLAN dropping. Using w/Jailbroken iPhone4+RoqyBT4+GP

Post by Gernby » Wed Oct 26, 2011 2:44 pm

I did some more testing on the drop-outs, and found that it isn't just the location of the Wiki Wifi that impacts drop-outs, it's also the orientation. I drove around my neighborhood, which has tons of homes with WiFi, and found that pointing the Wiki Wifi a certain direction caused it to drop out almost continuously. I think the solution will be different for every car, but I think it will just require you to test different locations and orientations within the vehicle to find the most stable connection.
Atomic Lutin
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 5
Joined: Thu Oct 20, 2011 9:13 pm

Re: OBD WLAN dropping. Using w/Jailbroken iPhone4+RoqyBT4+GP

Post by Atomic Lutin » Wed Oct 26, 2011 3:44 pm

Hi,

If it can help you :

I put the iPhone just behind the glass, and the kiwi wifi CLOSE to the iPhone. It drops with lap timer

I put the iPad near the gearbox, and the kiwi wifi anywhere in the car : With lap timer it drops, with DashCommand NO drop

I didn't try dash command with iPhone yet.
KrisS
20 or more Posts ★★★
20 or more Posts ★★★
Posts: 34
Joined: Sat Oct 01, 2011 9:13 pm

Re: OBD WLAN dropping. Using w/Jailbroken iPhone4+RoqyBT4+GP

Post by KrisS » Thu Oct 27, 2011 11:06 am

Harry

Sent you the UDID via forum PM.

Pls let me know how I could the test version of the app, what test,logging you want me to make, etc
User avatar
Harry
Site Admin
Site Admin
Posts: 9482
Joined: Sun Sep 12, 2010 10:32 am
Location: Siegum, Germany
Contact:

Re: OBD WLAN dropping. Using w/Jailbroken iPhone4+RoqyBT4+GP

Post by Harry » Sun Oct 30, 2011 8:22 am

Hi everybody,

As I received two additional confirmations that LapTimer 14.4 Release Candidate does not drop any more with the KiwiWifi, this can be considered solved. Reason was indeed that without the ATAT etc commands above, the Wifi dropped from time to time. The fix in LapTimer 14.4 can be considered a workaround as the command should actually not be necessary.

LT 14.4 will be available in 1 or 2 weeks.

:)

- Harry
Image Image Image Image
csmarx
20 or more Posts ★★★
20 or more Posts ★★★
Posts: 21
Joined: Wed Sep 07, 2011 11:30 am

Re: [SOLVED] OBD WLAN dropping. Using w/Jailbroken ...

Post by csmarx » Mon Dec 05, 2011 8:05 am

I've been struggling with my Kiwi Wifi not just dropping some data regularly, but also dropping off all together. Sounds like this should all be fixed in 14.4. Can't wait for it! Yay! :)

-Christian
Gernby
20 or more Posts ★★★
20 or more Posts ★★★
Posts: 21
Joined: Mon Oct 24, 2011 2:26 pm

Re: OBD WLAN dropping. Using w/Jailbroken iPhone4+RoqyBT4+GP

Post by Gernby » Mon Dec 05, 2011 6:25 pm

Harry wrote:Hi everybody,

As I received two additional confirmations that LapTimer 14.4 Release Candidate does not drop any more with the KiwiWifi, this can be considered solved. Reason was indeed that without the ATAT etc commands above, the Wifi dropped from time to time. The fix in LapTimer 14.4 can be considered a workaround as the command should actually not be necessary.

LT 14.4 will be available in 1 or 2 weeks.

:)

- Harry
It's been 5 weeks. Did something come up?
User avatar
Harry
Site Admin
Site Admin
Posts: 9482
Joined: Sun Sep 12, 2010 10:32 am
Location: Siegum, Germany
Contact:

Re: [SOLVED] OBD WLAN dropping. Using w/Jailbroken ...

Post by Harry » Tue Dec 06, 2011 8:25 am

Hi,

That's the reason for the delay: viewtopic.php?f=11&t=352

With TomTom, Emprum, and Dual support included, 14.4 was rejected by Apple.

I will wait until end of week and issue a version 14.4.1 without support for direct TomTom access then.

- Harry
Image Image Image Image
User avatar
fredsiva
10 or more Posts ★
10 or more Posts ★
Posts: 17
Joined: Fri Jun 03, 2011 5:11 pm

Re: [SOLVED] OBD WLAN dropping. Using w/Jailbroken ...

Post by fredsiva » Thu Dec 15, 2011 11:31 pm

just got my kiwi delivered today, and like many others, I also suffer from many disconnects in my Mini, despite various settings like suggested (Airplane mode, BT Off, ...).

I understand I shall patiently wait for 14.4 to have it fixed, thanks in advance for it!

Thanks Harry.
Post Reply