Lag between OBD data and recorded video overlay

Help on issues you run into with LapTimer; in case you have a question on how to use LapTimer, use the forum "Using LapTimer" instead
Post Reply
User avatar
Rupturedduck
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 3
Joined: Tue Dec 31, 2013 4:44 pm
Location: Somerset
Contact:

Lag between OBD data and recorded video overlay

Post by Rupturedduck » Wed Jan 01, 2014 2:27 pm

Hi Harry,

I've installed LapTimer Petrolhead (after your support this morning, thank you) on my iPhone5, connected to Mazda RX8 via wifi OBD2.

I've created a test video, and it has a lag between the throttle/RPM data recorded and the actual information. The delay is around 1 second. During the recording, the data displayed matched the actual RPM very closely, so I'm guessing the delay is happening during the overlay process? Is there a way to resolve this?

Thanks in advance for your assistance.
gplracerx
20 or more Posts ★★★
20 or more Posts ★★★
Posts: 836
Joined: Thu May 03, 2012 5:26 am
Location: Kingsport, TN USA

Re: Lag between OBD data and recorded video overlay

Post by gplracerx » Thu Jan 02, 2014 10:01 pm

Yes. First go to the charts to see if the GPS speed and the wheel speed are in sync. If not, you need to change the sensor delays. I can't remember which one you're supposed to change in which direction on that one. However, if they are in sync then it's likely the Overlay Synchronization is off. In Expert Settings (Settings/Expert Settings) scroll down to Overlay Synchronization. If I remember correctly, the default is 1 second. Set it to zero and tweak from there.
User avatar
Harry
Site Admin
Site Admin
Posts: 9402
Joined: Sun Sep 12, 2010 10:32 am
Location: Siegum, Germany
Contact:

Re: Lag between OBD data and recorded video overlay

Post by Harry » Thu Jan 02, 2014 10:50 pm

Thanks gplracerx :-)

@Rupturedduck, there are several threads on how to adjust the delays to get a perfect sync. You may have a look into viewtopic.php?f=6&t=1529&start=10 which includes some discussions on how to adjust both sensors delays and video / sensor synchronization.

- Harry
Image Image Image Image
User avatar
Rupturedduck
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 3
Joined: Tue Dec 31, 2013 4:44 pm
Location: Somerset
Contact:

Re: Lag between OBD data and recorded video overlay

Post by Rupturedduck » Fri Jan 03, 2014 2:37 pm

Thank you Harry, I did spend an hour or more trawling through search results prior to posting this. I am aware of forum etiquette. Please accept my apologies for not spending longer.

I will try out your suggestions, but I'll save it for when we are out testing the car.
User avatar
Harry
Site Admin
Site Admin
Posts: 9402
Joined: Sun Sep 12, 2010 10:32 am
Location: Siegum, Germany
Contact:

Re: Lag between OBD data and recorded video overlay

Post by Harry » Fri Jan 03, 2014 2:45 pm

No problem, sometimes it is about the correct search terms / key words too. In this case, try e.g. "delay", "sensor", and "ahead". The Google search feature in the top left of the dialog you get when selecting "Search" is by far better than the forum search engine displayed below that Google search.

- Harry
Image Image Image Image
Post Reply