Page 1 of 3

[FAQ] LapTimer doesn't rec. / records several laps in 1 lap

Posted: Sat Feb 26, 2011 11:46 pm
by Harry
Since version 17.5, LapTimer comes with a complete self check or "Health Status" making sure everything needed for successful lap recording is in place and working. The results of the check are shown in LapTimer's status bar:


So whenever LapTimer does not record data for you (or doesn't detect laps correctly), please check for the red alert first and read the details plus solution strategies provided within the app. There are some things however, that cannot be detected automatically and are listed here:
  • Health Status ignored: one must not ignore the red alert signal when it appears. Whenever you see the red alert, LapTimer will not work. So this is really no warning, but an error message! The most frequent issue related to missing recordings I get reported today is a special version of "Health Status ignored": the phone is stored away in a pocket or a glove box.
  • Smartphone put into your cloth: a frequent problem for motorbikers... They check the health status and find everything is o.k. Now, they put the smartphone into their cloth / leather. What happens is the following: GPS reception will degrade to near nothing within a few seconds, Health Status gets red - but is not seen. So never put your phone into your cloth. It simply does not work! Instead, please get a stable mount and add it to your windshield or steering rod.
  • Smartphone put to sleep or background: does not work either. LapTimer requires to run in foreground to record laps. Although part of LapTimer's functionality could be realized as a background service, it would be incomplete and mostly not working. Background operation is fine for GPS tools recording some positions every few seconds or minutes, but high frequency updates, acceleration recording, OBD recording, or video recording is not possible in background or will at least generate unpredictable results.
  • Driving a configuration the wrong way: To improve detection reliability, many track sets have triggers defined including a direction to be driven. While detection is improved when crossing such triggers, they will simply not fire in case you drive them the wrong way. So especially for tracks driven in both directions (clockwise and counter clockwise), please make sure you have loaded the track set matching your configuration.
In case the above issues are ignored and LapTimer is not able to detect lap splits reliably, you may end up with so called "multi-lap recordings" in your Lap List. Multi-lap recordings are continuous recordings not split up into laps when passing the start finish line. Although LapTimer has not been able to detect the start / finish line using standard trigger detection parameters, it may be possible to catch them using less strict settings. Here are the steps to split such recordings into laps "after the fact":
  • Make sure the track set is available and valid, reload the track set from Administration ‣ Add-ons.
  • Navigate to Administration ‣ Settings ‣ Expert Settings ‣ Trigger Detection.
  • To ease conditions for trigger detection, increase "Wide Corridor" beyond the standard "40 meters" and "Deviation Directed Trigger" beyond the standard value "60 degree". Start with 80 meters and 80 degrees.
  • Navigate to Analysis ‣ Lap List and select your multi-lap recording.
  • Scroll down to Data Recordings and press Recalculate ‣ Verify Lap. Follow instructions.
  • In case LapTimer is not able to detect all laps, return to Expert Settings and increase "Wide Corridor" in 20 meter steps.
  • Once the multi recording has been split correctly, purge the multi lap recording and reset Expert Settings to default values.
In case the recordings are too bad (missing GPS positions or very low accuracy), it will not be possible to split multi-lap recordings using the above procedure.

I hope that helps,


Re: LapTimer doesn't record / records several laps in one la

Posted: Wed Apr 27, 2011 10:28 pm
by gaskleppie
I had this problem yesterday at the Zandvoort circuit. It missed several times the start finish line. I use the tomtom cradle and normally have no problems with GPS measurements.
Here you can see the problem:
Right at the start finish line, it gets problems with the GPS. I think it has to do with the grandstand and pit building that is disturbing the GPS signal. As I drive next to the pit building, the points are further out of each other. Here you can see the Zandvoort pit buildings and grandstand:

My question is, does this loss in GPS signal disturb the lap timing, and what can I do in the advanced settings to get this problem solved? In the movie you can see that the start/stop of the laptiming is way off compared to the real start/finish line. What can I do to solve this?


Re: LapTimer doesn't record / records several laps in one la

Posted: Thu Apr 28, 2011 5:02 am
by Harry

The sample above is perfect ;-) The reason for the smaller number of fixes in the start / finish area is twofold: 1. You are fast in this area, so the fixes have a bigger distance between. 2. LapTimer has some data compression built in. Every time a fix can be reproduced by linear interpolation of two neighbor fixes, it is skipped. This situations appears on straights with not too much change in speed. You can turn off #2 in the Settings. This feature a reminiscence to the old PalmOS version were memory / space was a real problem.

- Harry

P.S. The problem I had in Zandvoort sometimes is a different one: in Hugenholtzbocht I had sometimes a lap splitted as the start / finish trigger is close to this corner. It helped to move the stop / go trigger somewhat down the straight to work around.

Re: LapTimer doesn't record / records several laps in one la

Posted: Thu Apr 28, 2011 4:51 pm
by gaskleppie
Ah, that explains the delayed start/stop at the straight. I see what you mean. Thanks a lot.
You can turn off #2 in the Settings.
i cant follow you here. What do you mean with this #2 in the settings? Cant find it.... Is this gonna help for the missing start/finish problem?

Re: LapTimer doesn't record / records several laps in one la

Posted: Thu Apr 28, 2011 7:06 pm
by Harry
Hi again,

turn off #2 means turn off the compression option. Goto Settings, you will find 'Compression' setting in the 'GPS' group.
The lap shown is fine. In case not all of them look like this, you probably need to move the start / stop trigger a bit to the east. I've placed it far to the west to work around the problem with Hugenholtzboch.

- Harry

Re: LapTimer doesn't record / records several laps in one la

Posted: Thu Apr 28, 2011 8:24 pm
by gaskleppie
Ok, I have set it to "none", I will test it later. I have a Intrax suspension test day at the 21st of June this year. If I remember, I will let you know if it helped.
Thanks a lot, you made a great laptimer!

Re: LapTimer doesn't record / records several laps in one la

Posted: Sun Apr 08, 2012 10:45 pm
by Raulr151 I believe I also had this problem. I used a preset track (Eagle Canyon Raceway) which had two POI's. I deleted one since I only wanted to use the one labeled as Start/Finish. As I made several laps it only recorded one lap at 24 minutes +. I'm slow but not that slow.

I am using a iPhone 3g model phone and had it in a pocket of my leathers on me.

Could it be the gps signal was too weak? It's gonna be bad if so and I have to buy a $100 piece of equipment for it to work well.... :(

Re: LapTimer doesn't record / records several laps in one la

Posted: Mon Apr 09, 2012 9:20 am
by Harry
Hi Raul,

Wearing any iPhone in your leather will degrade GPS quality to a point LapTimer has no chance to work with the data. As the iPhone3's had comparably weak GPSes, this is especially true here.

So please mount your device to the steering rod has proposed in LapTimer's help, this will work a lot better!

- Harry

two problems today: #1: doesn't auto-start at stop/finish

Posted: Wed Apr 11, 2012 1:57 am
by gshopper
First, thanks for writing a great app. I can't wait to get it up and working.

Went to the track today. I had a problem getting the app to start recording video when I crossed the start/ finish line. I set the app to record a video. the message said that it would automatically start when I crossed the start/ finish line. I went three sessions and it never triggered. I went to the finish line during the lunch break, and it worked fine (I was going about 5 mph at the time). But when i was at speed (100 mph) the app never started the video or timer. The start/stop line is midway through the straitaway, so speeds were high.

Interestingly, I had a friend's iPhone with your app, and it worked flawlessly. I don't know his settings, but it was probably the default settings, as he hadn't had a chance to set it up or change any settings.

I set the GPS for wide triggering, but it didn't help. I was getting good GPS reception; the meter was in the green. The phone was mounted on my windshield in the landscape position. I have an iPhone 4 with current IOS.

Any ideas why it didn't trigger?

P.S. I manually started the video and took a 20 minute video, which brings me the next problem (see next post).

Re: LapTimer doesn't record / records several laps in one la

Posted: Wed Apr 11, 2012 7:24 am
by Harry
Hi gshopper,

As you checked the GPS already (I understand you confirm it has been green all the time) it is about the triggers. Please check you have loaded the correct track set and see not any conflicts (red exclamation marks) in the Lap List. As your friend's configuration worked, compare both devices with the Lap List side by side. Check the section for your track - especially the first entry just below the track's section header.

- Harry