Slow OBD2 connection

Discussion related to external OBD sensors
wxywb021254
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 2
Joined: Mon Mar 07, 2016 6:34 am

Slow OBD2 connection

Postby wxywb021254 » Mon Mar 07, 2016 6:38 am

Hello, I have a 2004 Mazdaspeed Miata and recently I use Harry's lap timer just to record data. I found that Harry's lap timer always has very low fresh rate for OBD2 connection like 0.7HZ and it won't show info like gears. However, if I use other apps like torque lite and Racechrono, the fresh rate is much higher. How can I solve this problem? Thanks!


User avatar
Harry
Site Admin
Site Admin
Posts: 8949
Joined: Sun Sep 12, 2010 10:32 am
Location: Siegum, Germany
Has thanked: 98 times
Been thanked: 369 times
Contact:

Re: Slow OBD2 connection

Postby Harry » Mon Mar 07, 2016 8:16 am

Please search the forum for update rates - we had some discussions on this already. While LapTimer displays full fix update rates (set of all PIDs requested), most other apps show the PID rate. They differ by a factor or 5. So when seeing e.g. 2 Hz in LapTimer, the PID rate will be 10 Hz. Tap one of the rate gadgets to get PID rates instead of the default.

Values below 1 Hz need to be considered too slow nevertheless. For older cars (no CAN bus), a rate of 2 is what you can expect (10 Hz PID), for CAN cars it is between 8 and 30 (40 to 150 Hz PID).

So to start with, please name your configuration: OS, smartphone, car's year, OBD adapter.

Next, make sure you have *killed* other OBD apps when starting LapTimer. LapTimer closes sensor connections when being sent to background, others do not. This in turn will create conflicts making rates go down.

Verify you have no disturbing other Bluetooth devices in you car and disable them (car stereo e.g.).

If all of this doesn't help, please follow instructions on debugging OBD connections here on the forum (FAQ section).

Harry


Image Image Image Image
wxywb021254
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 2
Joined: Mon Mar 07, 2016 6:34 am

Re: Slow OBD2 connection

Postby wxywb021254 » Fri Mar 11, 2016 4:39 pm

Hello Harry, i ran a debug yesterday san sent you the datalog. Thank you for the help!


User avatar
Harry
Site Admin
Site Admin
Posts: 8949
Joined: Sun Sep 12, 2010 10:32 am
Location: Siegum, Germany
Has thanked: 98 times
Been thanked: 369 times
Contact:

Re: Slow OBD2 connection

Postby Harry » Fri Mar 11, 2016 6:28 pm

Several issues:

The initial negotiation on the bus protocol used is very slow and fails from time to time. This is not super critical because it will not disturb operation once connection making has been successful. It will simply make the startup lengthy. You may try to set a specific Default Protocol (in LapTimer ‣ Administration ‣ Settings ‣ Expert Settings ‣ OBD Tweaks). To understand which protocol is used by your car, please try SCANTOOL's app (OBDLink).

The best reply times from your car's bus are around 130ms. This means in best case it will deliver 7 to 8 PIDs per second. This corresponds to a display of 1 or 2 Hz in LapTimer. There is not a lot one can do on this, pre CAN busses are slow and will not deliver more than 2 Hz (corresponding to 10 PIDs/s).

The critical item is, the adapter delivered NO DATA frequently. This means a request has not been successful and should not happen. In case it happens, the systems waits for a timeout and the rate will drop even more. Please check you have ticked Ignore NO DATA/NAK Replies in Expert Settings first. In addition, please reduce the Reply Timeout to 0.30. This will reduce the pain, but not eliminate it.

One thing you can try to work around the NO DATA replies is switching Adaptive Timing from Optimized to Enabled. Although this setting is not the best for a well working combination, it will probably eliminate the NO DATA replies and bring you to a constant 1 or 2 Hz update rate.

- Harry


Image Image Image Image

Return to “OBD”

Who is online

Users browsing this forum: No registered users and 1 guest