New GoPoint BT1 continually drops out and reconnects

Discussion related to external OBD sensors
gripdaddy
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 4
Joined: Fri Jun 06, 2014 4:28 pm

New GoPoint BT1 continually drops out and reconnects

Postby gripdaddy » Mon Oct 13, 2014 1:48 am

Good evening,
I finally received my BT1 and noticed the following behavior. I plugged in the BT1 and loaded HLT. From the seniors page, I see the BT1 connected at 5-7 HZ. After a few seconds, the refresh rate will decease one hertz at a time until the green dot turns to yellow. The BT1 will then show not available for a second and then reconnect. Do I need to type something in the "Initialization" box that comes up if I tap the "i" icon next to the BT1? If I go to the Timer and then Video, I can see the ODB widgets. They will update, sometimes sluggishly, and will occasionally disappear for a second or two and then pop back up. I have made sure that the bluetooth from the car stereo is off and I have no other bluetooth gadgets in the vehicle. If I load GoPoint app and choose a point to graph, the data does not appear to drop out like it does in HLT.

This is on a iPhone 4S, HLT 18.3.4, iOS 7.1.2 and a Subaru BRZ.

Any ideas? Should I go ahead and submit a trace log?

Thanks!


User avatar
Harry
Site Admin
Site Admin
Posts: 8989
Joined: Sun Sep 12, 2010 10:32 am
Location: Siegum, Germany
Has thanked: 98 times
Been thanked: 378 times
Contact:

Re: New GoPoint BT1 continually drops out and reconnects

Postby Harry » Mon Oct 13, 2014 7:05 am

Yes, please send a trace log. For iOS7 this should actually work just fine. Before doing this, please switch Force Sequential Requests in Expert Settings to ON and make sure you have the latest BT1 firmware installed. Start with the last item and test each step before you try the next one.

Harry


Image Image Image Image
gripdaddy
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 4
Joined: Fri Jun 06, 2014 4:28 pm

Re: New GoPoint BT1 continually drops out and reconnects

Postby gripdaddy » Wed Oct 15, 2014 1:18 pm

Thanks for the info, Harry. What is the most up-to-date firmware for the BT1? I have 177.0.7. I have downloaded half a dozen GoPoint apps, but don't see in any of them how to update the firmware. If 177.0.7 isn't the latest revision, could you please give me a tip on how to update the firmware?

I did switch the Force Sequential Request setting and it seemed to help a lot. The BT1 will drop out once or twice when I first start Lap Timer, but after it gets a good connection, it will stay connected at 3-5 Hz and maybe drop out only once every 10 minutes.

I will try the trace log next. I just wanted to hear back on the firmware first to make sure to rule that out first.

Thanks again.


User avatar
Harry
Site Admin
Site Admin
Posts: 8989
Joined: Sun Sep 12, 2010 10:32 am
Location: Siegum, Germany
Has thanked: 98 times
Been thanked: 378 times
Contact:

Re: New GoPoint BT1 continually drops out and reconnects

Postby Harry » Wed Oct 15, 2014 2:38 pm

The firmware is fine, I run 177.0.6 currently. I'd be interested to get a log for the dropping configuration (i.e. parallel requests). Maybe this is a problem I have introduced with the last update. For me it works stable, but there are so many car configurations out there...

- Harry


Image Image Image Image
gripdaddy
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 4
Joined: Fri Jun 06, 2014 4:28 pm

Re: New GoPoint BT1 continually drops out and reconnects

Postby gripdaddy » Sun Nov 09, 2014 7:57 pm

Harry,
I apologize for the delayed response. I have sent you a log file of the parallel requests in GPS Buddy, but I am not sure how helpful it will be. When I run GPS Buddy, I do not experience the same issue that I do with Lap Timer. I tried toggling the various OBD options and they all seem to result in a steady 4-5Hz connection. I recorded a log file with all of the standard options and sent it to you. Please let me know if there is anything else that I can do on my end. Also, what is lost by toggling the "sequential requests" option?
Thanks!


User avatar
Harry
Site Admin
Site Admin
Posts: 8989
Joined: Sun Sep 12, 2010 10:32 am
Location: Siegum, Germany
Has thanked: 98 times
Been thanked: 378 times
Contact:

Re: New GoPoint BT1 continually drops out and reconnects

Postby Harry » Sun Nov 09, 2014 8:00 pm

Update rate / speed, parallel requests are faster than sequential requests. Have you tried turning it off? The will help when recording drop situations only...

Harry


Image Image Image Image
User avatar
Harry
Site Admin
Site Admin
Posts: 8989
Joined: Sun Sep 12, 2010 10:32 am
Location: Siegum, Germany
Has thanked: 98 times
Been thanked: 378 times
Contact:

Re: New GoPoint BT1 continually drops out and reconnects

Postby Harry » Sun Nov 09, 2014 8:01 pm

Buddy is working with sequential requests, I will change that some time to allow debugging this part.

Harry


Image Image Image Image

Return to “OBD”

Who is online

Users browsing this forum: No registered users and 2 guests