Intermittent comms with ODB BT1

Discussion related to external OBD and other sensors
Post Reply
kulbrand
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 5
Joined: Mon May 05, 2014 3:14 am

Intermittent comms with ODB BT1

Post by kulbrand » Sat Oct 04, 2014 2:25 am

Hi Harry, firstly thanks for a great app.

Have recently seen intermittent comms with the GoPoint BT1 unit. Works for a while 30-60 seconds, then stops, some times when on see gears shows one higher than actual and for some reason the speed shows 0 constantly. Though when ODB data disappears the speed comes back, off for a shorter time, then comes back again. This is in reference to timing screen with video; ODB data right bottom and speed & time left bottom.

The ODB rate shows red and zero all the time, in the GPS screen. Tried phone reset, bluetooth re-connect, ...

I am using iPhone 6, IOS 8.02, latest GP edition v18.3.4. (I am going to try an old 4 phone with IOS 7.1.3 and see if similar)

Might there be hardware problem with BT1 (year old latest firmware) or something in software still not totally cleared up?

Sent a log file from GPS buddy, just now, not sure how will show up, maybe look for first name, anyway above is context, and what to add is the car is 2013 BMW M5.

Anyone else seeing anything similar?

Thanks
Omar
User avatar
Harry
Site Admin
Site Admin
Posts: 9688
Joined: Sun Sep 12, 2010 10:32 am
Location: Siegum, Germany
Contact:

Re: Intermittent comms with ODB BT1

Post by Harry » Sat Oct 04, 2014 9:23 am

Hi,

There are no known issues with iPh6/iOS8.02/LT18.3.4 and the BT1. My first guess on situations like this is some disturbing other Bluetooth device or car stereo. So please recheck if you have any other smartphones etc with you either in "discovery mode" searching for peer devices, or even connecting the to BT1 in parallel. The later is a frequent effect when people start using a new smartphone.

The log you sent is too short. Ideally you generate one that includes a some range with the BT1 working, as well as the dropping situation. So please feel free to submit another log file with a longer time range.

All the effects described above are connection drops. Once the connection drops, GPS speed is used and will replace OBD speed. With no valid OBD speed, gears are screwed up etc. So these are all effects from an issue on device / connection level.

- Harry
Image Image Image Image
kulbrand
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 5
Joined: Mon May 05, 2014 3:14 am

Re: Intermittent comms with ODB BT1

Post by kulbrand » Sat Oct 04, 2014 9:18 pm

Thank you, think you are right. Tried in my other car 2008 128 and seamed to work ok there, although I had one brief complete drop out, refresh rate being 5-6 Hz. In the M5 still same problem, having turned off BT on stereo (also tried again stereo off and made sure no other BT devices around other than phone, at least that I know off.

Tried to submit another log file, hope I did this right, went for a drive recorded in Laptimer, and submitted the existing one from GPS buddy.

BT1 faulty ???

Thanks
Omar
M54ccibo
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 4
Joined: Fri Aug 23, 2013 6:53 am

Re: Intermittent comms with ODB BT1

Post by M54ccibo » Mon Oct 13, 2014 1:48 am

FWIW, I had an issue with my 2013 F10 M5 using the BT1 as well. I am also using an iPhone 6, IOS 8.0.2, and HLT 18.3.4. Constantly received a warning about OBD II update rate. For reference I had zero issues with Dash Command.

I decided to manually exclude a bunch of the OBD PIDs, and it looks like that worked. Wish I had come across that earlier. No biggie, as I excluded the OBD II data (which only had one entry in the CSV export) and utilized GPS speed for my video overlay.

For reference, here is the PID exclusion string which is excludes everything but VIN (0902), Throttle position (0111), Vehicle speed (010D) and Engine RPM (010C). I know that Harry suggests just removing a handful of the PIDs for rate issues, but since I don't need the others I just excluded them all:

09200940015C09000140012F0120011C010601050101010B0110
User avatar
Harry
Site Admin
Site Admin
Posts: 9688
Joined: Sun Sep 12, 2010 10:32 am
Location: Siegum, Germany
Contact:

Re: Intermittent comms with ODB BT1

Post by Harry » Mon Oct 13, 2014 7:09 am

PS: I need to correct my above answer. There are known issues with intermittent BT disconnects for iOS8.0.2. I assume they will be fixed in iOS8.1 expected later this month.

Harry
Image Image Image Image
kulbrand
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 5
Joined: Mon May 05, 2014 3:14 am

Re: Intermittent comms with ODB BT1

Post by kulbrand » Mon Oct 13, 2014 10:12 pm

M54ccibo, thanks for tips, will try. Force sequential to ON makes it work, at a stable 2-3 Hz refresh, when OFF the BT comms falls over immediately, turn to ON works again.
Harry, tanks for note on BT1. Just FYI, tried on my 2008 128i again and both modes work well "Force seq" ON 4 Hz, OFF 6 Hz, both stable.
Omar
Post Reply