Dual XGPS150a Refresh Rate @ 1Hz

Discussion related to external and internal GPS / GLONASS / Galileo / BeiDou sensors
Post Reply
kwan_1104
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 1
Joined: Wed Jul 24, 2019 12:48 am

Dual XGPS150a Refresh Rate @ 1Hz

Post by kwan_1104 »

Hi all,

Recently purchased a Dual XGPS150a from Amazon and downloaded the HLT App hoping to get some accurate lap times. However, when connecting the external GPS to HLP app, I noticed the refresh rate is stuck @ 1Hz rather than the 4/5Hz as advertised.

Upon searching, I noticed some people had to update to the latest firmware in order to "unlock" the higher refresh rate. So, I went on Dual's website and downloaded the latest firmware (v4.2.4).

Unfortunately, that did not work... So I was wondering if anyone know of a firmware version that has been proven to work?
IF so, it would be appreciated if you could send me a copy of the firmware version that works!!!

Thanks in advance!
aMacUzr
10 or more Posts ★
10 or more Posts ★
Posts: 16
Joined: Mon Oct 15, 2018 1:46 am

Re: Dual XGPS150a Refresh Rate @ 1Hz

Post by aMacUzr »

Don't know about the XGPS150 units, but my XGPS160 reverts to 1 Hz with LapTimer if I turn on the logging (i.e., tell the XGPS160 to record its GPS data). Turn off logging and it returns to 10 Hz.
gosborne
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 1
Joined: Sat Jul 27, 2019 6:22 pm

Re: Dual XGPS150a Refresh Rate @ 1Hz

Post by gosborne »

Kwan,

I had the a same issue – I recently purchased Dual xgps150a (with firmware 3.5.0 ) and have spent considerable time searching for a solution to set refresh rate to 5Hz. Here is what I did to get this to work at 5Hz.

DISCLAIMER - I can't say that this is a "supported" or proper approach but, it seemed to work for me.

Download Dual SkyPro GPS tool
Connect to the xgps150 with the SkyPro tool> Settings>Streaming rate> choose 5Hz (was set to 1Hz)
Close down SkyPro

Open HLT
Tap the MENU icon > Sensor list – you should see your XGPS150-XXXXXX selected (if not select it) with a green dot showing connected
Tap the XGPS150-XXXXXX and you should see SETTINGS options to select 5Hz (mine was set at 1Hz here)
Exit SETTINGS and you should see XGPS150-XXXXXX showing connected @5Hz (mine showed connected @2Hz and in a few seconds ramped up to 5Hz)
Go back to the menu and tap GPS and hopefully in the lower right corner you will see Rate at 5Hz.
Post Reply