Debugging DIY 10Hz...

Discussion related to external and internal GPS sensors
DitPun
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 1
Joined: Mon Oct 16, 2017 9:02 pm

Debugging DIY 10Hz...

Postby DitPun » Sun Oct 22, 2017 12:16 am

Dear All, I was inspired by this DIY:

https://did-it-myself.com/diy-10hz-blue ... -receiver/

...to try my hand at making a similar device, though with connectivity with iOS. Due to the various issues in connecting regular Bluetooth devices to iOS, I used an HM-10 BLE device instead of the HC-06 used in the above link. Also, I used the "Adafruit Ultimate GPS Breakout" module (MKT3339 based) for GPS.

The good news is that using a BLE terminal app (Bluetooth Serial) on my iPhone, I was able to connect to the HM-10 and was able to see the GPS messages as they streamed in. I was also able to send commands to change to RMC, the update rates, etc. However, the LapTimer app didn't connect via Custom GNSS BLE. In light of the fact that nothing else recognized the data stream as GPS, I'm going to assume the issue is that this simple circuit is not sending the correct GATT service codes to the phone, though I'll have to admit my knowledge of BLE protocols is elementary.

Note that I also have an HC-06, and when I plugged this into the circuit, it was recognized by my old Samsung Note as a GPS device.

Any thoughts on if this kind of simple GPS->CLE device can work with iOS? If not, I'm going to try the Arduino based solution using WiFi that was posted a few days ago.

Thanks!


User avatar
Harry
Site Admin
Site Admin
Posts: 8744
Joined: Sun Sep 12, 2010 10:32 am
Location: Siegum, Germany
Has thanked: 97 times
Been thanked: 359 times
Contact:

Re: Debugging DIY 10Hz...

Postby Harry » Mon Oct 23, 2017 2:41 pm

Hi,

Please apply to participate in our Developer Program: send your mail address and forum id to Harry@gps-laptimer.de
We can log what is going on with the communication once you are in.

- Harry


Image Image Image Image
nathan8
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 1
Joined: Tue Feb 27, 2018 2:27 pm

Re: Debugging DIY 10Hz...

Postby nathan8 » Tue Feb 27, 2018 2:32 pm

Hi

I appreciate this is a bit old, but I am at the same point.

BLE does not pair with the device but communicates a stream direct to Apps.
I can see this with a BLE program (bluetooth serial).

But cannot get Harry's laptimer to see it. I tried a few items in the sensor list, but suspect that the Custom BTLE GNSS is the right one.

Did this get anywhere?

BR - Nathan

(HM10 to iphone).(Tried HC06 and HC05 - iphone will not pair with those. Problematic!)


User avatar
Harry
Site Admin
Site Admin
Posts: 8744
Joined: Sun Sep 12, 2010 10:32 am
Location: Siegum, Germany
Has thanked: 97 times
Been thanked: 359 times
Contact:

Re: Debugging DIY 10Hz...

Postby Harry » Thu Mar 01, 2018 10:28 am

Information on the developer program is available in http://www.gps-laptimer.com/LapTimerDoc ... rogram.pdf Please note this is on v22 already, but will give you an idea for the current v21 implementation too. Without developer program, the Custom BTLE GNSS option is the way to try.

- Harry


Image Image Image Image

Return to “GPS”

Who is online

Users browsing this forum: No registered users and 1 guest