Dual XGPS160

Discussion related to external and internal GPS sensors
User avatar
Harry
Site Admin
Site Admin
Posts: 8879
Joined: Sun Sep 12, 2010 10:32 am
Location: Siegum, Germany
Has thanked: 97 times
Been thanked: 365 times
Contact:

Re: Dual XGPS160

Postby Harry » Mon Mar 27, 2017 5:20 pm

Thanks, I have another report here in Germany. Same thing, XGPS stops delivering data for both LapTimer and Dual's app.

- Harry


Image Image Image Image
gplracerx
20 or more Posts ★★★
20 or more Posts ★★★
Posts: 826
Joined: Thu May 03, 2012 5:26 am
Location: Kingsport, TN USA
Has thanked: 11 times
Been thanked: 30 times

Re: Dual XGPS160

Postby gplracerx » Mon Mar 27, 2017 9:37 pm

Harry wrote:Thanks, I have another report here in Germany. Same thing, XGPS stops delivering data for both LapTimer and Dual's app.

- Harry


By the way, the other iPhone that was able to read data from the XGPS160 for a while while the first iPhone (5s. iOS 10.2.1) was not updating, was a 4s (iOS 9.5.3) . But it stopped eventually too. I'm going to update the 5s to iOS 10.3 and see if it makes a difference. I'm not holding my breath.


User avatar
Harry
Site Admin
Site Admin
Posts: 8879
Joined: Sun Sep 12, 2010 10:32 am
Location: Siegum, Germany
Has thanked: 97 times
Been thanked: 365 times
Contact:

Re: Dual XGPS160

Postby Harry » Mon Mar 27, 2017 9:56 pm

I have reported to Dual, they are working on this.

- Harry


Image Image Image Image
gplracerx
20 or more Posts ★★★
20 or more Posts ★★★
Posts: 826
Joined: Thu May 03, 2012 5:26 am
Location: Kingsport, TN USA
Has thanked: 11 times
Been thanked: 30 times

Re: Dual XGPS160

Postby gplracerx » Tue Mar 28, 2017 2:21 pm

As expected, the behavior of iOS 10.3 was no better.


cgroppi
10 or more Posts ★
10 or more Posts ★
Posts: 14
Joined: Wed May 25, 2011 6:37 pm

Re: Dual XGPS160

Postby cgroppi » Wed Mar 29, 2017 5:13 am

Harry wrote:Thanks, I have another report here in Germany. Same thing, XGPS stops delivering data for both LapTimer and Dual's app.

- Harry


I had exactly the same problem this past autocross event. It was extremely frustrating. I eventually put the phone and GPS in the glove compartment and gave up after the phone lost connection to the GPS the third time in the same event. I had to reboot the phone and power cycle the GPS to fix it.

-Chris


User avatar
Harry
Site Admin
Site Admin
Posts: 8879
Joined: Sun Sep 12, 2010 10:32 am
Location: Siegum, Germany
Has thanked: 97 times
Been thanked: 365 times
Contact:

Re: Dual XGPS160

Postby Harry » Wed Mar 29, 2017 6:31 am

In situations like this, turn off the XGPS und use the internal GPS. That's better than nothing.

Harry


Image Image Image Image
gplracerx
20 or more Posts ★★★
20 or more Posts ★★★
Posts: 826
Joined: Thu May 03, 2012 5:26 am
Location: Kingsport, TN USA
Has thanked: 11 times
Been thanked: 30 times

Re: Dual XGPS160

Postby gplracerx » Wed Apr 05, 2017 10:00 pm

I'm trying an experiment. It turns out that you don't need the iOS app to update the firmware. You can do it with a PC after downloading the firmware from the Dual web site. It also looks like iOS users should stay with firmware versions 1.x.x. The current version of this series is 1.5.1. I've replaced 2.4.1 with 1.5.1 and am testing to see if the update rate goes to zero in about ten minutes. So far, so good.

Edit: Twenty one minutes and counting. I think that may have done it.


cgroppi
10 or more Posts ★
10 or more Posts ★
Posts: 14
Joined: Wed May 25, 2011 6:37 pm

Re: Dual XGPS160

Postby cgroppi » Sun Apr 09, 2017 4:35 am

I just downgraded my firmware to 1.5.1. We'll see if that solves the problem.

-Chris


Reedey
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 4
Joined: Tue Aug 26, 2014 11:24 am

Re: Dual XGPS160

Postby Reedey » Sun Apr 09, 2017 1:28 pm

Mine is bricked as heeelll.

I traveled a lazy 15000km's to the Nurburgring last week and the night before we hit the track I was sitting in the hotel getting my gear prepared and I thought i'd update the firmware just cause it felt like the right thing to do.

Turns out that was a bad idea.

The Bluetooth synced no problems and I thought everything was fine, but at the end of the day when I was reviewing the data I realized that my data looked very poor. Turns out it had been recording at 1hz all day using the iPhone GPS. Strange.

So I try to connect using the app and even tho the bluetooth is working, no status, no data, nothing appears in the app at all and Harry's doesn't seem to recognize the external receiver at all.

I search the forum and find that there is a new version of the app, and installing from the old one kills it.

Great, so I install the new app, which also won't connect and sometimes tells me that I need to email Dual to get information on how to update the firmware on my XGPS150. I don't have a 150, I have a 160.

The new version of the app somehow managed to connect to it exactly once but it would crash as soon as I tried to do anything and have not been able to replicate at all.

So I checked the website, downloaded the desktop software to run an update via USB. Still no luck. Nothing seems to be working at all now.

The one time I managed to get it to connect did show the datalogs from the day so I have some faith that I might still be able to retrieve the traces, but for now I am stuck with a device that is bricked as f*#k and dual labs who never answer emails ever.


Reedey
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 4
Joined: Tue Aug 26, 2014 11:24 am

Re: Dual XGPS160

Postby Reedey » Mon Apr 10, 2017 9:41 pm

Ok Dual eventually got back to me.

Steps below describe the reset process
1. With the power on, on the GPS, slide the switch to the other position, wait three seconds, slide the switch back to apple (XGPS150 only)
2. Power off the XGPS
3. On your phone, go into Settings > Privacy > Location Services, Turn off location
4. Power of your phone
5. Turn your phone back on, go into Settings > Privacy > Location Services, Turn on location
6. Turn on the XGPS
7. Connect through Bluetooth

This appears to have fixed it. Relief!



Return to “GPS”

Who is online

Users browsing this forum: No registered users and 1 guest