Dual XGPS160

Discussion related to external and internal GPS sensors
User avatar
Harry
Site Admin
Site Admin
Posts: 8297
Joined: Sun Sep 12, 2010 10:32 am
Location: Cologne, Germany
Has thanked: 96 times
Been thanked: 343 times
Contact:

Re: Dual XGPS160

Postby Harry » Sat Jun 11, 2016 10:37 am

The problem is not that the internal GPS takes over, but that LapTimer releases any resources when sent to background. LapTimer must not be sent to background during operation, this will neither work with an external nor an internal GPS. Screensaver is disabled in all racing relevant screens anyway (Timer, Speedo, Engine, GPS, Video, etc).

Harry


Image Image Image Image
scociu
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 6
Joined: Tue Jul 26, 2016 8:43 am
Been thanked: 1 time

Re: Dual XGPS160

Postby scociu » Tue Jul 26, 2016 8:49 am

Anybody got issues with one these devices? I think mine is bricked: Just received it, updated the firmware and now i can't use it. The skypro app doesn't connect properly, it only reads battery level and firmware version and the device never locks on satellites (green light always blinking).
Is there any way to revert to older firmware?


BT1 - XGPS160 - iphone 5s - Alfa 156 GTA 2003 (OBD2 no can)
User avatar
Harry
Site Admin
Site Admin
Posts: 8297
Joined: Sun Sep 12, 2010 10:32 am
Location: Cologne, Germany
Has thanked: 96 times
Been thanked: 343 times
Contact:

Re: Dual XGPS160

Postby Harry » Tue Jul 26, 2016 8:52 am

The initial lock can take quite some time after having reset a GPS or updated its firmware. In case it does not lock even when outside for some minutes, I'd suggest to contact Dual support.

- Harry


Image Image Image Image
scociu
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 6
Joined: Tue Jul 26, 2016 8:43 am
Been thanked: 1 time

Re: Dual XGPS160

Postby scociu » Tue Jul 26, 2016 8:57 am

Did a 30 minute drive and a 15 minute walk, no lock. I think the device is bricked.
Yeah, contacted their support was the first thing i did, don't have my hopes high though as they seem to have a bad reputation of not answering at all.


BT1 - XGPS160 - iphone 5s - Alfa 156 GTA 2003 (OBD2 no can)
User avatar
Harry
Site Admin
Site Admin
Posts: 8297
Joined: Sun Sep 12, 2010 10:32 am
Location: Cologne, Germany
Has thanked: 96 times
Been thanked: 343 times
Contact:

Re: Dual XGPS160

Postby Harry » Tue Jul 26, 2016 8:58 am

scociu wrote:Did a 30 minute drive and a 15 minute walk, no lock. I think the device is bricked.
Yeah, contacted their support was the first thing i did, don't have my hopes high though as they seem to have a bad reputation of not answering at all.


Drop me a mail in case you have problems with support.

- Harry


Image Image Image Image
scociu
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 6
Joined: Tue Jul 26, 2016 8:43 am
Been thanked: 1 time

Re: Dual XGPS160

Postby scociu » Tue Jul 26, 2016 3:24 pm

Fixed it after a phone call at their customer support. I suggest everybody complaining about no answer to support emails to do the same.
Turns out that the "SkyPro app" they refer on the website to be used with the device is obsolete and there is a newer "dual xgps status" app that should be used instead. After upgrading the firmware through this app everything works fine.

On my way to test LapTimer it is then :)


BT1 - XGPS160 - iphone 5s - Alfa 156 GTA 2003 (OBD2 no can)
jwmelvin
20 or more Posts ★★★
20 or more Posts ★★★
Posts: 52
Joined: Fri Oct 18, 2013 1:28 pm
Has thanked: 1 time
Been thanked: 2 times

Re: Dual XGPS160

Postby jwmelvin » Wed Jul 27, 2016 11:43 pm

Thanks for the info!


tooheybill
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 7
Joined: Sun May 10, 2015 8:14 am

Re: Dual XGPS160

Postby tooheybill » Sun Jan 08, 2017 3:53 am

Hi,
My Dual XGPS160 appear to have died about November 2016. I am still on Firmware Version “1.4.1”. Should that still work with the latest HLT 10.2.4 that has support for Dual v2.2.1?
Thanks in advance.


User avatar
Harry
Site Admin
Site Admin
Posts: 8297
Joined: Sun Sep 12, 2010 10:32 am
Location: Cologne, Germany
Has thanked: 96 times
Been thanked: 343 times
Contact:

Re: Dual XGPS160

Postby Harry » Tue Jan 10, 2017 11:25 am

See my other reply, both "latest" firmware versions are supported now.

- Harry


Image Image Image Image
gplracerx
20 or more Posts ★★★
20 or more Posts ★★★
Posts: 813
Joined: Thu May 03, 2012 5:26 am
Location: Kingsport, TN USA
Has thanked: 11 times
Been thanked: 30 times

Re: Dual XGPS160

Postby gplracerx » Mon Mar 27, 2017 3:39 pm

The update rate of my XGPS160 goes to zero after 5 to 10 minutes. It's still connected. The only fix seems to be turning the XGPS160 off and back on again. Sending the app to the background doesn't work. I've tried the usual stuff, forgetting all bluetooth devices, turning off bluetooth and rebooting and then reconnecting. I'm using 2.4.1 firmware.

The same thing happens with the Dual XGPS Status Tool app. I'll try another device.

I connected a second iPhone and it works even though the first iPhone is still not updating. So it's not the XGPS160.



Return to “GPS”

Who is online

Users browsing this forum: No registered users and 2 guests