Possible cosmetic bug: Video export speed given as 1/x ?

A number of ways you can support LapTimer development
Post Reply
User avatar
planetshg
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 8
Joined: Mon May 01, 2017 3:44 pm
Location: Wuppertal, Germany

Possible cosmetic bug: Video export speed given as 1/x ?

Post by planetshg » Thu Jun 01, 2017 9:40 pm

Situation:
When overlaying a video, a notification informs about the relative progress, frames processed as well as heap memory and "speed".
For example: "[...] speed x3,5"

Expectation:
I understand speed as a moving window over the last second, given by the fraction of the current overlay speed performance, measured in fps, over the raw video's fps.
Similar definitions could be found to consider the total process speed instead of a moving window covering the last second gone by.
That so, I would expect speed ratings above 1 to indicate faster processing than the video's fps/realtime - the video should be processed in less time than it would take to play it at recording speed.

Behaviour:
When looking at the time taken for some count of frames to be processed, it seems to me that speed is given reciprocally according to above definition: Sub-realtime processing shows as speed ratings above 1.

Proposal:
Inverse speed rating.
Or delete thread as trivial / not a business case / OBD interp is much more important. ;-)

Cheers,
Philipp
User avatar
Harry
Site Admin
Site Admin
Posts: 9077
Joined: Sun Sep 12, 2010 10:32 am
Location: Siegum, Germany
Contact:

Re: Possible cosmetic bug: Video export speed given as 1/x ?

Post by Harry » Fri Jun 09, 2017 12:34 pm

It is an abbreviation for "speed of overlaying is 3,5 times the time of the lap". So if the recording is two minutes, the overlay will require 7 minutes to be completed.

- Harry
Image Image Image Image
Post Reply