Known Bugs and Issues in LapTimer v15

All announcements that are outdated are moved here.
Locked
User avatar
Harry
Site Admin
Site Admin
Posts: 9540
Joined: Sun Sep 12, 2010 10:32 am
Location: Siegum, Germany
Contact:

Known Bugs and Issues in LapTimer v15

Post by Harry » Tue May 01, 2012 8:37 pm

This thread is to document known problems and resolutions.

I have added some color coding to see for which bugs fixes are available already (green - solved) or will be available in the future (red - open).

LapTimer crashes the second time passing a stop/go trigger while video recording - This problem is one I would rate 'severe' as it had an effect on many users during the first days LapTimer v15 has been released. The problem has been fixed in version 15.0.2

LapTimer stops with a message on a problem with the database that could not be recovered - After quite some testing and investigation, the root cause for the problem has been identified: LapTimer creates a copy of the database during startup to recover from crashes. iOS on the other hand limits the time for startup of an app. Due to the copy process, some devices took too long for the startup and consequently where killed by iOS - in the middle of creating the named copy. When LapTimer has been started the next time, it found this incomplete copy and crashed. The problem has been fixed in version 15.0.2 and should not occur newly. However, the problem may still be present on your device as it has been introduces in v15.0 / v15.0.1. So I have added some recovery routines in 15.0.2 to help users with corrupted databases to get back to a valid state without starting over. This recovery routines sometimes crash themselves (in case the corrupted database is too corrupted :-) ). This issue has been fixed in version 15.0.3 More on this topic is available here.

LapTimer crashes in Splitted Lap List and / or Vehicle List on devices running iOS 4.x This issue occurred especially on iPads that mix the Vehicle and Lap List. In case the Lap List is the default view (the one used in the end of the session before), this crash may occur during LapTimer startup too. This issue has been fixed in version 15.0.3

LapTimer offered an overlay option named 'Lead Titles' that lead to dropped frames and crashes during overlaying This function is actually not production ready but has been made available accidentally in version 15.0.1 Removed in version 15.0.2 again.

LapTimer loses links between laps and videos during updates When LapTimer is updated (e.g. using a bug fix release), it loses links to videos stored within LapTimer's Documents folder. Links to the Photo Library are not affected. You can manually restore this links by pressing 'Select' in Lap Details and re-select the video. In case you have recorded multi-lap videos, you need to set the sync point in addition. More on this can be found here: http://www.gps-laptimer.de/Video.html This issue has been fixed in version 15.0.3 This version will automatically restores old links and updates them.

LapTimer doesn't warn if track set conflicts occur This is a minor one as it will not impact operation as long as no conflicting track sets are loaded. Nevertheless, please take care you do not load more than one track configuration at one time. This issue has been fixed in version 15.0.3

Unsuccessful video transfers (Move) from LapTimer to Photo app break link between lap and video The link is changed to point to the Photo library despite the video has not been moved. Users can manually relink the video - which oddly is a complex task. This issue is fixed in version 15.0.4

The 'Staged' button is unresponsive on the Video ViewCan probably be worked around by closing the dialog (press black cross button) and using the large 'Staged' button embedded in the Video View. This issue is fixed in version 15.0.4

LapTimer misses triggers while using high precision GPS accessories When detecting triggers, LapTimer always adds the current accuracy to the corridor of detection. This means with low accuracy the corridor is wide and with high accuracy it is tight. It turns out that the new accuracies calculated for Emprum, Dual, et al reduces the corridor to an extent LapTimer misses well positioned triggers. This issue is fixed in version 15.0.5

LapTimer v15.0.4 versions mixes up the data recording records You can identify the problem easily by pressing "Check Data" in the Lap List. In case it gives you "1 error fixed" continuously (instead of really fixing it), you have this issue. The symptoms in general are crashes or missing data recordings. This issue is fixed in version 15.0.5 Data recordings currently not visible any more, will appear again. Please do not delete laps / record new ones while having this issue.

Hope this helps you in case you run into problems. I try to send fixes to AppStore as soon as possible.

- Harry
Image Image Image Image
spearfish25
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 1
Joined: Mon Sep 10, 2012 1:43 am

Re: Known Bugs and Issues in LapTimer v15

Post by spearfish25 » Mon Sep 10, 2012 1:44 am

I don't see a way to attach videos in the iPhone's photo folder any longer. Is this feature still available so one can overlay onto external videos?
User avatar
Harry
Site Admin
Site Admin
Posts: 9540
Joined: Sun Sep 12, 2010 10:32 am
Location: Siegum, Germany
Contact:

Re: Known Bugs and Issues in LapTimer v15

Post by Harry » Sun Sep 16, 2012 10:13 am

spearfish25 wrote:I don't see a way to attach videos in the iPhone's photo folder any longer. Is this feature still available so one can overlay onto external videos?
I assume you are on v16 already? Just asking because this v15 thread is outdated...
You can link Photo library videos like before: select the Lap in Lap List, press Edit, press Add Video, and select any video you have in your Photo library.

In case you need further support, please open a new thread in Troubleshooting or Using LapTimer. :-)

- Harry
Image Image Image Image
Locked