Dual XGPS150 5Hz support

News and updates from the author // Read only
User avatar
Harry
Site Admin
Site Admin
Posts: 8372
Joined: Sun Sep 12, 2010 10:32 am
Location: Cologne, Germany
Has thanked: 97 times
Been thanked: 349 times
Contact:

Re: Dual XGPS150 5Hz support

Postby Harry » Tue Sep 03, 2013 7:26 pm

Please check the articles on this thread (and others). Several users had problems loading the update. Changing to another machine / different USB port / Windows version helped. On the firmware update in general: this 4/5 Hz firmware has been added as a special edition for LapTimer users (and probably others with high update rate requirements). This is the reason it is not preloaded always.

- Harry


Image Image Image Image
wtam608
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 1
Joined: Sun Dec 01, 2013 9:07 pm

Re: Dual XGPS150 5Hz support

Postby wtam608 » Sun Dec 01, 2013 9:22 pm

Just purchased Dual 150a. It came with 1.3.1 firmware. It seems to be working without any issue (In the Satellites and Senor List options). However, after finished the run... from "Lap List" speed information shows only ave of 1 mile, GPS sensor show "Internal @ 1.0 Hz".

Do I need to turn off the internal GPS? If so, how - I don't see any way the IOS can turn off the GPS setting. (ISO 7.0.4)

Thank you.


User avatar
Harry
Site Admin
Site Admin
Posts: 8372
Joined: Sun Sep 12, 2010 10:32 am
Location: Cologne, Germany
Has thanked: 97 times
Been thanked: 349 times
Contact:

Re: Dual XGPS150 5Hz support

Postby Harry » Mon Dec 02, 2013 10:00 am

wtam608 wrote:Just purchased Dual 150a. It came with 1.3.1 firmware. It seems to be working without any issue (In the Satellites and Senor List options). However, after finished the run... from "Lap List" speed information shows only ave of 1 mile, GPS sensor show "Internal @ 1.0 Hz".

Do I need to turn off the internal GPS? If so, how - I don't see any way the IOS can turn off the GPS setting. (ISO 7.0.4)

Thank you.


In case LapTimer detects a XGPS, it turns off the internal GPS automatically. No need to switch it off...
Nevertheless, the above message means the Dual is not currently connected to LapTimer. Check the following items / follow the listed steps:

  • Check LapTimer / Settings / Expert Settings / Accessory Tweaks / Use Accessories -> needs to be ON
  • In case that doesn't help. Turn off the Dual, send LapTimer to background. Turn on the Dual again. Make sure the Dual and your iPhone connect (check the the BT icon in the status bar. Pull LapTimer to foreground and check the GPS source again (Sensor List).

- Harry


Image Image Image Image
gplracerx
20 or more Posts ★★★
20 or more Posts ★★★
Posts: 814
Joined: Thu May 03, 2012 5:26 am
Location: Kingsport, TN USA
Has thanked: 11 times
Been thanked: 30 times

Re: Dual XGPS150 5Hz support

Postby gplracerx » Mon Dec 02, 2013 5:20 pm

Do I need to turn off the internal GPS? If so, how - I don't see any way the IOS can turn off the GPS setting. (ISO 7.0.4)


Airplane mode turns off the internal GPS as does turning off Location Services in the Settings/Privacy menu. Turning off Location Services does other things as well which may or may not be advantageous. In Airplane mode, you have to turn Wi-Fi and Bluetooth back on in the Settings menu.

When I have communication difficulty with my XGPS160, I go to the Bluetooth menu and un-pair (forget) the device and then pair it again. You can have a situation where the GPS shows 'connected' in the Bluetooth menu but HLT doesn't get data. I'm pretty sure that's a problem with iOS and not Dual or HLT. It's not as bad in iOS 7 as it was in iOS 6.



Return to “Announcements”

Who is online

Users browsing this forum: No registered users and 1 guest