Status of HERO5 support

News and updates from the author // Read only
User avatar
Harry
Site Admin
Site Admin
Posts: 8370
Joined: Sun Sep 12, 2010 10:32 am
Location: Cologne, Germany
Has thanked: 97 times
Been thanked: 349 times
Contact:

Re: Status of HERO5 support

Postby Harry » Wed Mar 15, 2017 1:57 pm

Please multiply LapTimer update rates roughly by 5 to get the raw update rate. So if the OBDLink app shows 11-12 (raw rate), LapTimer will display 2 Hz. Why is this? Please check this link: viewtopic.php?f=20&t=3389&p=17186&hilit=net+gross+rate#p17186 The link includes information on where to see the raw rate in LapTimer too. ;-)

LapTimer has a highly optimized integration with ELM327 adapters, I've spend weeks with tweaking this part. I'm not aware of any relevant improvement potential any more.

As LapTimer interpolates engine data to frames (30Hz), you will not see a difference between e.g. 2 and 10 Hz OBD rates. If you see "jumping" values, this is usually because there is some issue with repeated cached data returned from the adapter generating "steps" which cannot be interpolated, or a combination of GPS and OBD update rates LapTimer does not cope with well. The former (stepped data) will not occur for OBDLink products. In case you want to further investigate, please play with the "OBD Extrapolation" expert setting.

- Harry


Image Image Image Image
User avatar
wbrian200
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 4
Joined: Sun Mar 12, 2017 1:29 am

Re: Status of HERO5 support

Postby wbrian200 » Thu Mar 16, 2017 2:33 am

Thanks for the information. I think I understand most of what you're saying, and that other thread is very informative. I will mention, after playing with some of the OBD expert settings, I did end up getting a displayed OBD rate of 9-11 hz at the sensors section. The things I set specifically to achieve this were Default protocol to 15765-4 CAN (11 bit, 500 kbps), I left Adaptive Timing in optimized after trying other options and not really seeing any benefit, I set CAN Multi requests to 3 PIDs/Adaptive, UART Baud rate set to 500kbps, and OBD Extrapolation to Conservative. However, after reading the OBD Extrapolation description again, and based on what you're saying, I should try Aggressive to possibly remedy the "steps"?

I did do a 2nd video with the above settings and it seemed to me that it was a bit better, but perhaps it was a pseudo effect knowing the OBD was communicating at what I thought was a higher rate, but I'm guessing just the raw rate I somehow managed to pull into the app (I'm guessing thats what the CAN Multi requests setting did). I'd be happy to share that video if you would like to see it for comparison.

Regarding the interpolation of laptimer data to frames, which you reference as 30 hz, would I be better served recording at 30 fps? All of my testing to this point has taken place at 60 fps. Logic tells me if the video is updating twice as fast as the overlay all on the same display, I'm bound to see some artifacts/anomalies. Thanks for your help. I really love the app so far, and can't wait to get it on the track!


User avatar
Harry
Site Admin
Site Admin
Posts: 8370
Joined: Sun Sep 12, 2010 10:32 am
Location: Cologne, Germany
Has thanked: 97 times
Been thanked: 349 times
Contact:

Re: Status of HERO5 support

Postby Harry » Thu Mar 16, 2017 12:09 pm

Data is interpolated to each frame. So saying 30 Hz is just for videos recorded at 30 fps. In case you are using 60 fps, LapTimer will interpolate to 60 Hz etc. To answer your question on aggressive vs. conservative, I need both the rate for your GPS and the OBD.

- Harry


Image Image Image Image
User avatar
wbrian200
Fewer than 10 Posts
Fewer than 10 Posts
Posts: 4
Joined: Sun Mar 12, 2017 1:29 am

Re: Status of HERO5 support

Postby wbrian200 » Thu Mar 16, 2017 1:20 pm

OBD is 9-11, GPS is 9-10. Thanks!


User avatar
Harry
Site Admin
Site Admin
Posts: 8370
Joined: Sun Sep 12, 2010 10:32 am
Location: Cologne, Germany
Has thanked: 97 times
Been thanked: 349 times
Contact:

Re: Status of HERO5 support

Postby Harry » Fri Mar 17, 2017 3:22 pm

wbrian200 wrote:OBD is 9-11, GPS is 9-10. Thanks!


For this combo, LapTimer will choose the conservative approach by default. So please try aggressive and check if you see a difference. NB: this setting applies for new recordings only. Existing recordings are not changed "after the fact".

- Harry


Image Image Image Image
User avatar
metro2084
20 or more Posts ★★★
20 or more Posts ★★★
Posts: 21
Joined: Mon Mar 14, 2016 4:53 am
Has thanked: 6 times
Been thanked: 1 time

Re: Status of HERO5 support

Postby metro2084 » Sat Mar 18, 2017 7:06 pm

I never tried using external cam before and I got now hero5. People here are saying it works with hero4 settings. So I set it up as hero4, it says it's connected, but I don't see video feed on my phone from hero5. I just was out on the track and I was thinking it was recording, but looks like it wasn't.
Any suggestions?
Thank you.


User avatar
Harry
Site Admin
Site Admin
Posts: 8370
Joined: Sun Sep 12, 2010 10:32 am
Location: Cologne, Germany
Has thanked: 97 times
Been thanked: 349 times
Contact:

Re: Status of HERO5 support

Postby Harry » Sat Mar 18, 2017 7:20 pm

metro2084 wrote:I never tried using external cam before and I got now hero5. People here are saying it works with hero4 settings. So I set it up as hero4, it says it's connected, but I don't see video feed on my phone from hero5. I just was out on the track and I was thinking it was recording, but looks like it wasn't.
Any suggestions?
Thank you.


When taking about HERO 5 compatibility, it is about the Black, not the Session model. In case you have a 5 Black, please have a look into Video Documentation available from www.gps-laptimer.de/documentation. Connecting external cams to your smartphone can be tricky.

- Harry


Image Image Image Image
User avatar
metro2084
20 or more Posts ★★★
20 or more Posts ★★★
Posts: 21
Joined: Mon Mar 14, 2016 4:53 am
Has thanked: 6 times
Been thanked: 1 time

Re: Status of HERO5 support

Postby metro2084 » Sun Mar 19, 2017 10:09 pm

Harry, so I was trying to figure out how to transfer hero5 video to iPhone and use both videos from iPhone and gopro (PiP). When I had both videos on the screen, looks like I accidentally tapped on red circle on master video (iPhone video) and it deleted. Is there a way to bring it back? Maybe it should ask for confirmation before deletion?

And another question, when setting up overlaying video from hero5 (adding intro/extro etc) the app reacts extremely slow. It could take up to a minute to react to my tap. Is this normal?

Thank you.
Last edited by metro2084 on Sun Mar 19, 2017 10:32 pm, edited 1 time in total.


User avatar
Harry
Site Admin
Site Admin
Posts: 8370
Joined: Sun Sep 12, 2010 10:32 am
Location: Cologne, Germany
Has thanked: 97 times
Been thanked: 349 times
Contact:

Re: Status of HERO5 support

Postby Harry » Sun Mar 19, 2017 10:29 pm

There has been a double confirmation already: you need to swipe and press delete, or press edit and select delete. Apple's human interface style guide suggests exactly this to protect destructive actions. Only in case a single button press is possible, an extra confirmation is necessary (and LapTimer implements destructive actions exactly like this). I certainly understand that someone who deleted something accidentally would have preferred another's confirmation - but this is a burden you put on everyone wanting a convenient option to delete something (without three steps).

Please check if you still have the original video on your SD card and transfer it again? Undo options are not available on smartphones (for similar reasons), it is not possible to restore the deletion.

Harry


Image Image Image Image
User avatar
metro2084
20 or more Posts ★★★
20 or more Posts ★★★
Posts: 21
Joined: Mon Mar 14, 2016 4:53 am
Has thanked: 6 times
Been thanked: 1 time

Re: Status of HERO5 support

Postby metro2084 » Sun Mar 19, 2017 10:33 pm

that was master video from the iPhone, it was not on the sd card =(

Could you please answer my second question from previous post?



Return to “Announcements”

Who is online

Users browsing this forum: No registered users and 1 guest